cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Adde1
Level: Powered On

Issue with syncing data from CDS back to Talent

I'm experiencing a strange behavior in CDS when updating CDS data through the data integrator in Power apps.

 

Workflow steps explanation:

 

The worker data is exported from Talent through the worker entity through a requrring job in data management framework. The data is pushed to an external azure sql  database. The only entity used in the export is the Worker entity. The data is fetch from the Azure SQL database through an external on-premise AD integration. If the mail address is empty then the AD will create a new user and send back the mail address to a new table in the same Azure SQL. The table only contains PersonnelNumber and the PrimaryMailAddress.

Then a project is created in Data integrator in Power apps to read the table that only contains PersonellNumber and the PrimaryMailAddress. The only thing the project does is to map and replace the data in CDS. The newly updated mail address should now get reflected in Talent but this does not happen.   

 

These are the steps that I have done:

 

  • Created a Trial Environment in PowerApps, CDS 2.0(The latest) with Contoso data
  • Created a new Talent instance in LCS connecting to the above CDS,
  • Created a Azure SQL database
  • Connected the Azure SQL database in Talent: "Configure entity export to database" in "Data management" under "System Configuration"
  • Created a new table in the database with two columns: PersonnelNumber, PrimaryMailAddress 
  • Published the Worker(HcmWorker) entity to the database
  • Created an export job in Talent for the worker entity with incremental push enabled connecting to the external Azure SQL database
  • I created a new row in the new table: PersonnelNumner = 000001, PrimaryMailAddress: test@hotmail.com
  • I change the mail address in Talent to test@outlook.com and I can see that the CDS data for the worker entity is updated after doing a new incremental push from Talent. So the data push from Talent to CDS is working
  • I created a new "Data integration" project in Power apps with the Azure SQL database connector. I connected the connector to the new Table. I choose only to update data in the project. Then I mapped the primary key in the CDS entity(cmd_worker) to PersonnelNumber in my table and mapped PrimaryMailAddress in CDS(cmd_worker) to PrimaryMailAddress in my table. Noting else is done
  • I run the project manually and can see that the CDS data for PrimaryMailAddress gets updated with test@hotmail.com which is correct

 

The problem is that Talent never gets updated with the new mail address.

Another strange thing is if I update the mail address in Talent for the same user the new mail address never gets updated in the CDS. So somehow after doing an update from outside into the CDS the connection between Talent and the CDS gets corrupted.

 

We are looking for an urgent help,

 

Thanks in advance

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

SecondImage

Follow PowerApps on Twitter

Stay Up-to-Date by following PowerApps on Twitter

Top Community Contributors for July 2019

Top Community Contributors for July 2019

Let's thank our top community contributors

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

FifthImage

Dynamics 365 and Power Platform April 2019 Release notes

Features releasing from April 2019 through September 2019!

Users Online
Currently online: 46 members 4,147 guests
Please welcome our newest community members: