cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
hshah
Level: Powered On

Powerapp connected to database with on premise gateway

Hi,

 

we created a powerapp that connects to sql database using on premise gateway and has been working properly since few months. Recently it has started to have issues with search not displaying results and database not refreshing/updating itself. I have tried manual refresh with database too. I have tested the connection to database and gateway and seems ok. Error message on the main screen when I go to Edit the app is attached. Please advise.

 

Is there any related updates that has been rolled out?

 

Thanks

 

Harry

 

1 ACCEPTED SOLUTION

Accepted Solutions
hshah
Level: Powered On

Re: Powerapp connected to database with on premise gateway

This issue is resolved. I deleted the sql connection. In the app, click on View menu-> Data Sources, select old one and click remove. Removed store procedure. Edited store procedure to use newly created connection. added store procedure again and added parameters. Made sure none of the properties/commands were referring to old connection.

 

The cause of the issue is still unknown.

 

Tested, worked ok.

 

 

View solution in original post

7 REPLIES 7
MartinK1704
Level: Powered On

Re: Powerapp connected to database with on premise gateway

Hi Harry, 

I have a problem with the onprem Connection when I install a new Version of a logic app. 
My work arround is: Create a new Connection from the Logic app editor and delete the old connetion.
Did you try to delet the connection and create a new one?

Best regards
Martin

Community Support Team
Community Support Team

Re: Powerapp connected to database with on premise gateway

hI @hshah ,

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned.

 

Based on the screenshot that you provided, I think this issue may be related to the SQL Server connection you added within your app.

 

Please check if the On-Premise Data Gateway within your PC is the latest version, if not, please consider upgrade it to the latest version.

 

Also please consider re-move the previous SQL Server connection from your app, then re-create a new connection to your SQL Server from your app using your On-Premise Data Gateway, then try your formula again, check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
hshah
Level: Powered On

Re: Powerapp connected to database with on premise gateway

I created the same connection again with no issues. However, when I reference it in the app, same message appears

Community Support Team
Community Support Team

Re: Powerapp connected to database with on premise gateway

Hi @hshah ,

Is the version of your On-premise data gateway the latest version?

 

Currently, I could not reproduce your issue on my side. Please consider take a try with the following steps to fix this issue:

1. Check if the version of your On-premise data gateway is the latest version, if not, please upgrade it to latest version firstly.

2. Clear Cache of your browser.

3. Sign in your PowerApps, then go to the Connection Lists, remove all SQL Server connections there.

4. Create an app, then add a new SQL Server connection within your app using your On-premise Data Gateway.

 

More details about removing connection from Connection List, please check the following article:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/add-manage-connections#update-or-delete...

 

If the issue still exists, please consider submit an assisted support ticket through the following link:

https://powerapps.microsoft.com/en-us/support/pro

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
hshah
Level: Powered On

Re: Powerapp connected to database with on premise gateway

Performed all three steps. Deleted the sql connection, created again but now cannot add it back again in the app. Fails to load the table. There are no issues with the database itself.

 

See attached screenshot.

 

hshah
Level: Powered On

Re: Powerapp connected to database with on premise gateway

Performed all three steps. Deleted the sql connection, created again but now cannot add it back again in the app. Fails to load the table. There are no issues with the database itself.

 

See attached screenshot.

hshah
Level: Powered On

Re: Powerapp connected to database with on premise gateway

This issue is resolved. I deleted the sql connection. In the app, click on View menu-> Data Sources, select old one and click remove. Removed store procedure. Edited store procedure to use newly created connection. added store procedure again and added parameters. Made sure none of the properties/commands were referring to old connection.

 

The cause of the issue is still unknown.

 

Tested, worked ok.

 

 

View solution in original post

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Top Kudoed Authors (Last 30 Days)
Users online (4,938)