cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Caroline
Level: Powered On

Resource principal not found in tenant

I have recently needed to re-install my Office profile which has resulted in the excel PowerApps add-in not being able to find the resource principal in the tenant. 

I recall having this issue before, and someone walked me through how to reset it, but I don't recall how.

Can anyone help please?

 

 

2 REPLIES 2
Community Support Team
Community Support Team

Re: Resource principal not found in tenant

Hi @Caroline ,

 

Please follow below steps to have a try:

  1. On powerapps.com, expand the Data section and click or tap Entities in the left navigation pane. All the entities are shown.
  2. Click the ellipsis (...) to the right of the entity that you're interested in.
  3. Click Open in Excel, and then open the workbook that is generated. This workbook has binding information for the entity, a pointer to your environment, and a pointer to the PowerApps Excel Add-in.
  4. In Excel, click Enable editing to enable the PowerApps Excel Add-in to run. The Excel Add-in runs in a pane on the right side of the Excel window.
  5. If this is the first time that you've run the PowerApps Excel Add-in, click Trust this Add-in to allow the Excel Add-in to run.
  6. If you're prompted to sign in, click Sign in, and then sign in by using the same credentials that you used on powerapps.com. The Excel Add-in will use a previous sign-in context and automatically sign you in if it can. Therefore, verify the user name in the upper right of the Excel Add-in.

The Excel Add-in automatically reads the data for the entity that you selected. Note that there will be no data in the workbook until the Excel Add-in reads it in.

 

Regards,

Mona

 

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Caroline
Level: Powered On

Re: Resource principal not found in tenant

@v-monli-msft Thanks for the reply. I am opening the file using the same process as you have stated. It now states that O365 has been configured to prevent aquisition and execution of add-ins, even though I have been granted full permission to do so.

I've logged a ticket.