cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
drewski
Level: Powered On

Something went wrong Error - Unable to import model-driven package

I have a Model-Driven app using CDS that was developed by an outside development company.

 

They sent me the package (created in their tenant) and now I'm trying to import it into my companies environment.

 

Every time I try to import I get a generic "Something Went Wrong, Please try again later" error with no furhter details.

 

The zip file contains 3 xml files (Content Types, Customizations, Solution) and 2 folders for Formulas & Workflows.

 

This was developed with the sole purpose of importing it into our environment. Is there something in the package that needs to be tweaked in order to upload or any other method for figuring out the root cause of the import error? 

 

Thanks as always PA community! 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Super User
Super User

Re: Something went wrong Error - Unable to import model-driven package

Hi @drewski ,

 

This error could have happened due to the following reasons, kindly check if any of these works: 

 

1. Check if you have enough permissions to import a solution in the environment that you are importing this.

2. The error might be due to some dependency components that the model driven app depends on and those are not present in the environment. 

 

Hope this helps!

 

Thanks. 

4 REPLIES 4
Super User
Super User

Re: Something went wrong Error - Unable to import model-driven package

Hi, 

 

Model driven apps are based on the entities/ components of a solution. Kindly check that all the componenets required by the app are present in your environemnt. If you can share a screenshot of the error that you are getting, we might be able to help you in a better way. 

 

 

Thanks, 

Community Support Team
Community Support Team

Re: Something went wrong Error - Unable to import model-driven package

Hi @drewski 

 

Could you please share more details of your situation?

Could you please reference this firstly?

https://powerapps.microsoft.com/nl-nl/blog/powerapps-packaging/

 

Hope this could be helpful.

 

Best Regards.

Yumia

drewski
Level: Powered On

Re: Something went wrong Error - Unable to import model-driven package

Trust me, I wish the error would provide more details.. I attached a screenshot. Looking to try and figure out the root cause of the error as there is nothing to go off of.


I have reviewed the link on packaging and importing.. it's very generic and I have gone through the steps of importing a zip package.

 

Super User
Super User

Re: Something went wrong Error - Unable to import model-driven package

Hi @drewski ,

 

This error could have happened due to the following reasons, kindly check if any of these works: 

 

1. Check if you have enough permissions to import a solution in the environment that you are importing this.

2. The error might be due to some dependency components that the model driven app depends on and those are not present in the environment. 

 

Hope this helps!

 

Thanks. 

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

FirstImage

Power Platform World Tour

Coming to a city near you

thirdimage

PowerApps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

FourthImage

Join PowerApps User Group!!

Connect, share, and learn with your peers year-round

SecondImage

Power Platform Summit North America

Register by September 5 to save $200

Users Online
Currently online: 192 members 4,631 guests
Please welcome our newest community members: