cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Tekmerion
Level: Powered On

Unable to export data for Entities

I am unable to export data for any Entities from the database in my Default environment.

 

When I attempt to complete the export, I receive an error that results in the output of a .zip file.  When I download that file, it contains a CSV file titled "Project Validation.csv".  Inside the .csv file is the following error message: "Connection validation failed. Connection '2c43fcb8-5337-480f-98dc-f975ccceb342-default.cds.DM' does not exists."

 

Can anyone help me regarding how to correct this problem?

 

 

4 REPLIES 4
Community Support Team
Community Support Team

Re: Unable to export data for Entities

Hi @Tekmerion ,

Could you please share a bit more about the error message?

Does this error message occur when you export your CDS Entities data from your PowerApps Environment?

 

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. Please consider clear cache of your browser, and then sign in your PowerApps again, check if the issue is solved.

 

Please also check if you have proper permission to export data from the CDS in your PowerApps environment. Please make sure you have been assigned proper Security Role within the PowerApps Environment, so you could access data in the CDS.

 

If the issue still exists, please consider submit an assisted support ticket for further help through the following link:

https://powerapps.microsoft.com/en-us/support/pro

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Tekmerion
Level: Powered On

Re: Unable to export data for Entities

@v-xida-msft  - Thanks for responding - here is the additional information you requested:

 

Yes - this error message/file is generated when I try to export the data from my CDS Entities to a file from my Default environment.  Also - I created another (Production) environment and am able to export the data from the CDS Entities in that environment to a file without any error - so the problem seems specific to my Default environment.

 

I am pretty sure that I have the correct security/permissions assigned in the environment, as I am able to access all of the CDS Entities - AND - I am also able to export all of the Entity data from my Default environment to an Azure Data Lake Gen2 using the "Export To Data Lake" feature - so it seems specific to exporting to a file.  My challenge is that I have some Custom Entities that are not being exported to the Data Lake (they seem to be "invisible" to the new export function) - so I want to export their data to a file and then I'm going to figure out how to manually add them into the Data Lake.

 

I have tried flushing the cache on my browser - have even tried other browsers - and nothing worked.

 

So - I think it is time to open the Support ticket now.

 

Thanks again!

Community Support Team
Community Support Team

Re: Unable to export data for Entities

Hi @Tekmerion ,

Have you taken a try with the "Edit data in Excel" functionality in CDS Entity?

 

On your side, please consider take a try with the "Edit data in Excel" functionality in CDS Entity, then the data structure and all records of the Entity would be exported into a Excel file in your Local PC, then you could copy the data from the exported Excel file, then import it into your Azure Data Lake:

1.JPG

 

Please also consider take a try with above solution, then check if the issue is solved.

Note: Please also make sure your PowerApps License is valid, and not be expired.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Tekmerion
Level: Powered On

Re: Unable to export data for Entities

The Edit in Excel option works - but I see it as a workaround to the fact that the actual feature to export to a file is not working - and generates an error message every time.  I'm hesitant to mark this as resolved when the original issue that I posted is not actually fixed.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

Users Online
Currently online: 303 members 5,708 guests
Please welcome our newest community members: