cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
PMavrich
Advocate II
Advocate II

All of my flows that use Trello once worked (for several months) but are now failing

I have built approximately 15 flow that work with Trello in some way, either creating a card or using a move of a card as a trigger.  They were all working fantastically, but now all of a sudden, none of them work.  I have tried signing back into the power app.  I removed all of the connectors to Trello and reestablished a new one. With no success.  I am not sure what is going on, but these flows automate a large engineering process and currently it is all down.  How do I get it back up and working.  Is there possibly an issue with the connection that is more than just me.  Any assistance would be appreciated.

 

Thanks a bunch

1 ACCEPTED SOLUTION

Accepted Solutions

Well, I had to delete and replace all of my trello content in all 21 flows inorder to make them work again.  Not sure what caused the issue or if it will come back, but currently everything is running after a whole 24 hours of work. 😞

 

@Expiscornovus 

@yashag2255 

View solution in original post

18 REPLIES 18
yashag2255
Dual Super User II
Dual Super User II

Hi @PMavrich 

 

Can you please share a screenshot of the error (if you are getting any) or the current state of the flow where the connection is not getting recognised? or any errors notifications that you are getting? That way we might be able to assist you better. 

yashag2255
Dual Super User II
Dual Super User II

@yashag2255 

 

There is no error for the ones that are triggered by moving a card in trello.  The below issues are happening with all my flows that have a connection in some way to trello.

 

first.JPGsecond.JPGthird.JPG

yashag2255
Dual Super User II
Dual Super User II

HI @PMavrich 

 

In the first screenshot I see that the Create a Trello card action is not succeeding and the reasons might be: 

1. The board that you are trying to create the card to has been deleted/ closed. Please check and confirm if this is not so. 

2. Parent list ID of the board has been modified. Kindly check this on the board in trello and make necessary changes in the flow 

3. You might be referencing an external variable to add to the card name of the Trello card create action and for some reason that is not being fetched. can you check this? maybe post a screenshot of the flow for a better look at it (barring any sensitve info)

 

As you have mentioned that all your flows are failing at Trello, I am guessing that the reason is either p1 or p2. 

 

The second screenshot has an error in the List comments of a card action and that is due to the wrong ID. All the more reason for me to guess that there have been some changes made on the trello account that might have deleted the board and took this card. If this list comments action is for the card you created in the previous step, then it won't fetch anyways as the card was not created. 

 

The last error looks like of an excel list rows action for a particular key value and I am guessing that this has soemthing to do with the trello card and the data is not being fetched/created in excel to amtch and list the rows. 

 

Kindly check the trello board and confirm if everything is as is over there. 

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

@yashag2255 

 

This issue is effecting 21 of my flow processes out of 23 total flows I have.  They refer to different trello boards and multiple excel spreadsheets.  NONE of my flows are working that use Trello in some form.  Nothing has changed in 17 of the flows that use the Trello boards, they  just stopped working.  Its a blanket issue.  

 

The flows that are triggered by a card moving in trello do not work at all, because the trigger just doesnt happen.

yashag2255
Dual Super User II
Dual Super User II

@PMavrich 

 

Can you post a screenshot of the trigger that you are using? ("The flows that are triggered by a card moving in trello do not work at all, because the trigger just doesnt happen.")

argh.JPG

yashag2255
Dual Super User II
Dual Super User II

@PMavrich Everything here seems good. I tried replicating the flow and it works fine in my environemnt. Can you please confirm the security roles at the trello board?

ksh.png

 

@yashag2255 

 

All the boards that I am working with are team boards

@yashag2255 

 

I had my coworker log into the Trello connection and received the same error

Then I removed the create a card and added it back and had the same results.

yashag2255
Dual Super User II
Dual Super User II

@PMavrich 

For a quick test, can you start a new flow, manually triggered and the action List cards in a board and select the board that you are using in the previous flows and run and see the results?

Don't know if it is related. But can you elaborate on the settings/configuration of the boards? Are you using any specific Power-Ups or do you maybe use some of the new features?

 

Of course the Trello product team is also constantly changing their platform, so maybe it's related to one of those changes:

https://trello.com/b/dQHqCohZ/trello-platform-changelog

Edit: sorry for the same reply twice. WiFi connection on the train is bad 😉

@Expiscornovus @yashag2255 

I don't use any of the new features.

 

I had one board linked to JIRA. 

 

I only changed the email frequency.  

 

board permission.JPGemail.JPG

Well, I had to delete and replace all of my trello content in all 21 flows inorder to make them work again.  Not sure what caused the issue or if it will come back, but currently everything is running after a whole 24 hours of work. 😞

 

@Expiscornovus 

@yashag2255 

View solution in original post

yashag2255
Dual Super User II
Dual Super User II

HI @PMavrich  There might have been some change either in the connector or the configuration in Trello or some piece that Flow was unable to connect to in its state of the earlier connection with Trello and that has caused this issue. Apart from that, there is no reason why this would not work. But finally now it does!

 

If my reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

@PMavrichgood to hear that it works. Bad that it took 24 hours of work 😞

 

Hopefully this won't happen again in the near future.

Hey, @PMavrich !

Thanks so much for posting in the Flow Community! It appears that you have found a solution to your issue!

If so, please click "Accept as Solution" on the reply that describes how you were able to solve your issue!

This makes your post much easier for other members of the community to see and find when looking for a solution! 

Thanks so much! 

 

Happy Flowing! 

 

- Gabriel
Community Manager
Power Automate | Power Virtual Agents
Super User Program Manager



Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (1,754)