cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
New Member

Another RSS feed error

I am trying to create a flow which filters a RSS feed and send to Slack, but ran into RSS feed error

 

URL of RSS feed: http://www.theedgemarkets.com/mycorporate.rss

 

Inputs

Outputs

Headers

{
  "Pragma": "no-cache",
  "x-ms-request-id": "d0e2fb43-478f-46f7-8dfa-e3f13149d719",
  "X-Content-Type-Options": "nosniff",
  "Cache-Control": "no-cache",
  "Date": "Wed, 12 Apr 2017 11:25:04 GMT",
  "Set-Cookie": "ARRAffinity=29e552cea7db23196f7ffa644003eaaf39bc8eb6dd811911f669d13ab7424faf;Path=/;Domain=127.0.0.1",
  "Server": "Microsoft-IIS/8.0,Microsoft-HTTPAPI/2.0",
  "X-AspNet-Version": "4.0.30319",
  "X-Powered-By": "ASP.NET",
  "Content-Length": "175",
  "Content-Type": "application/json; charset=utf-8",
  "Expires": "-1"
}

 

Body

{
  "status": 400,
  "message": "Failed to read requested Feed information. Details: Element 'channel' with namespace name '' was not found. Line 3, position 6.",
  "source": "127.0.0.1"
}

 

 

What is the problem and how to solve this?

4 REPLIES 4
Community Support
Community Support

Hi dennislee,

 

From the error message, it seems that there is something wrong with the feed.


I have found a link on my side, please check it for a reference:
http://stackoverflow.com/questions/15915049/error-loading-rss-xml-element-channel-with-namespace-nam...

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Mabel Mao,

But i did tried using FeedBurner, it was able to parse the RSS url successfully

 

RSS URL: http://www.theedgemarkets.com/mycorporate.rss

FeedBurner feed: http://feeds.feedburner.com/theedgemarkets/Kfdi

 

Could it be the case that Flow's RSS parser too strict and FeedBurner was able to accept wider variety of RSS feeds?

I just looked into this.  Looks like you didnt specify the right RSS feed URL.  Can you add a screenshot of the error to validate that?  The feed that didnt work is: http://feeds.theedgemarkets.com/theedgemarkets/mymarkets.rss

 

I tried this and it works for me as well - adding a screeshot.

 

image.png

 

 

The problem has be resolved after few days of my report...i guessed @v-yamao-msft 

Helpful resources

Announcements
Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Kudoed Authors
Users online (27,856)