cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
annajhaveri
Super User
Super User

Azure Key Vault Connection - Get Secret action

Hello,

 

I want to get value of Secret from Azure Key Vault, but when i add Get Secret action to the Flow, the Flow is not able to connect to Azure Key Vault, i am getting invalid connection error, as shown in below screenshots. The goal of using Azure Key Vault is to get the client secret stored in vault, that client secret will be used in Graph API action in the Flow as we dont want store the client secret directly in the variable and we would want to store it in Azure Key Vault for security reasons.

 

 

  1. Could not retrieve values. Key 'vaultName' not found in connection Profile. When i add the action i see a textbox to enter vault name but then Flow automatically tries to connection with the account and shows this message \Annotation 2020-04-30 215735.png
  2. Flow shows invalid connection error, even though the account connected to the Action has access to Azure Key Vault and account is added under Access Policies in Azure Key VaultAnnotation 2020-04-30 215747.png
  3. When i go to Data -> Connections, the status column of the Azure Key Vault connection, the Status is "Parameter Value Missing"Annotation 2020-04-30 215752.png

Thanks in advance for any help if someone provide to solve this issue, to be able to connect to Azure Key Vault successfully from Power Automate (Flow).

 

Thanks,

Anna Jhaveri 

Regards,
Anna Jhaveri

If I have answered your question, please mark the post as Solved to help other users to identify the correct answer
If you like my response, please give it a Thumbs Up.
3 REPLIES 3
Rahber
Super User
Super User

Hello, This would normally happen when the you have inserted the azure key vault action for the first time and it tries to create a connection with same ID you are creating the flow.

 

In the process it bypasses the step where it needs you to enter the Key Vault Name. So the simple solution is go to connections page. Click edit on the connection for Azure Key Vault. Enter your vault name, fix the sign in issue i.e. authenticate again. Go back to the flow and click on the connection again and your problem will be solved.

 

Thanks,

Rahber

kelway
Advocate I
Advocate I

Just to add - that the Connections page is under the "Data" menu of Power Automate.

petestanley
New Member

Thanks @Rahber , @kelway your comments really helped!

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,426)