cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
esamudio
Level: Powered On

Bad Gateway error| Get Items (Limit columns by View)

Hi,

 

Flows were running successfully for few weeks and now they are failing for couple of days. As soon as we remove 'Limit Columns by View' option, the flow succeeds. when we limit the columns by view, it fails giving the  bad gateway error.

 

badgateway.PNGbadgateway1.PNG

 
Any pointers would be highly appreciated.
 
Thanks.
4 REPLIES 4
stschilar
Level: Powered On

Re: Bad Gateway error| Get Items (Limit columns by View)

Any response or resolution?  I am having the same issue.  Bad Gateway error since yesterday 8/14/18...  

Community Support Team
Community Support Team

Re: Bad Gateway error| Get Items (Limit columns by View)

Hi @esamudio,

 

Could you please share more details about the configuration of your flow? 

 

If the error code 502 appears, the failure is temporary or transient. Click or tap Resubmit to try the flow again, or please create a new flow to see if the issue still exists.

 

I have made a test on my side and don't have issue that you mentioned. 

 

The screenshot of my flow as below:

 Capture.PNG

 

The flow would run successfully as below:

 Capture.PNG

 

 

Best Regards,

Alice

esamudio
Level: Powered On

Re: Bad Gateway error| Get Items (Limit columns by View)

Hi Alice,

 

I am still facing the issue. I recreated a new workflow with Sharepoint Get Items action. As you can see, if I keep Limit columns by View blank, workflow runs fine but if limit columns by view then it fails with error 'Badgateway'. This was working fine before. It has stopped working since Aug 10, See the screenshot below.

 badgateway.PNGbadgateway1.PNG

 

Thank you.

 

Highlighted
stschilar
Level: Powered On

Re: Bad Gateway error| Get Items (Limit columns by View)

I ended up doing what @esamudio did - recreated my workflows without limiting my columns to a specific view (I originally had 2 views and only wanted to track the changes of certain fields within each view).  For now this seems to be working.  

 

FYI - Microsoft did call and take a couple of screen shots, but no additional information as of yet.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (5,445)