cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Bad Gateway error| Get Items (Limit columns by View)

Hi,

 

Flows were running successfully for few weeks and now they are failing for couple of days. As soon as we remove 'Limit Columns by View' option, the flow succeeds. when we limit the columns by view, it fails giving the  bad gateway error.

 

badgateway.PNGbadgateway1.PNG

 
Any pointers would be highly appreciated.
 
Thanks.
4 REPLIES 4
Highlighted
Frequent Visitor

Re: Bad Gateway error| Get Items (Limit columns by View)

Any response or resolution?  I am having the same issue.  Bad Gateway error since yesterday 8/14/18...  

Highlighted
Community Support
Community Support

Re: Bad Gateway error| Get Items (Limit columns by View)

Hi @esamudio,

 

Could you please share more details about the configuration of your flow? 

 

If the error code 502 appears, the failure is temporary or transient. Click or tap Resubmit to try the flow again, or please create a new flow to see if the issue still exists.

 

I have made a test on my side and don't have issue that you mentioned. 

 

The screenshot of my flow as below:

 Capture.PNG

 

The flow would run successfully as below:

 Capture.PNG

 

 

Best Regards,

Alice

Highlighted
Frequent Visitor

Re: Bad Gateway error| Get Items (Limit columns by View)

Hi Alice,

 

I am still facing the issue. I recreated a new workflow with Sharepoint Get Items action. As you can see, if I keep Limit columns by View blank, workflow runs fine but if limit columns by view then it fails with error 'Badgateway'. This was working fine before. It has stopped working since Aug 10, See the screenshot below.

 badgateway.PNGbadgateway1.PNG

 

Thank you.

 

Highlighted
Frequent Visitor

Re: Bad Gateway error| Get Items (Limit columns by View)

I ended up doing what @esamudio did - recreated my workflows without limiting my columns to a specific view (I originally had 2 views and only wanted to track the changes of certain fields within each view).  For now this seems to be working.  

 

FYI - Microsoft did call and take a couple of screen shots, but no additional information as of yet.

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (7,389)