cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Can't connect to Azure Dev Ops

I'm trying to create a flow to create an issue at Azure Dev Ops (former VSTS) whenever an email is received.

 

I don't have any trouble connecting to Outlook.com, but when I try to create the connection to Azure Dev Ops an error shows up in the popup window with a Bad Request message in it (HTTP Error 400).

 

I've seen that in the connections list, the Azure Dev Ops connections is still a Preview, but almost all of them are.

 

This is a known issue? There is any solution?

 

Thank you

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Frequent Visitor

Re: Can't connect to Azure Dev Ops

Same here. I've tried again, doing the exact same thing, and this time worked.

 

Thanks

View solution in original post

14 REPLIES 14
Highlighted
Community Support
Community Support

Re: Can't connect to Azure Dev Ops

Hi @naulacambra,

 

I have made a test on my side and don't have the issue that you mentioned.

 

I could create a connection to Azure Dev Ops with no error.

 

Please take a try to create the connection with correct account information.

 

Best regards,

Alice

Highlighted
Frequent Visitor

Re: Can't connect to Azure Dev Ops

Hi @v-yuazh-msft,

 

Thank you for your response, but I still cannot connect to Azure Dev Ops.

 

I've tried Chrome (my usual browser), Microsoft Edge and Mozilla Firefox, all of them with the same result.

 

Steps:

1. Sign in into Microsoft Flows and go to Connections

1.PNG

2. Try to create an Azure Dev Ops new connection

2.PNG

 

3. When I click on "Create" a sign-in popup shows up, and without letting me try to sign in, a 400 HTTP Error appears3.PNG

 

This is the url on the popup 

https://app.vssps.visualstudio.com/oauth2/authorize?client_id=64A11F15-53A8-40BB-AB1B-1EF6EB495373&r...

 

Anything that I should try?

 

Thank you

Highlighted
Regular Visitor

Re: Can't connect to Azure Dev Ops

This is the exact error that I am facing
Highlighted
Frequent Visitor

Re: Can't connect to Azure Dev Ops

Naulacambra 

 

Do you have at least access in Devops to create a story,bug or anything else  since your error message seems like it could be an issues with what level of access you have

Highlighted
Frequent Visitor

Re: Can't connect to Azure Dev Ops

I use the Dev Ops on my work daily, with full access, being able to manage work items. I've never had any permissions issue when working directly at Dev Ops.

Highlighted
Frequent Visitor

Re: Can't connect to Azure Dev Ops

Did you also try another browser and do you have a Personal account with Microsoft that it could be trying to use and not your normal one for Dev ops since I do have 2 acccounts one for personal and one for work with the same email which does cause some issues. 

Highlighted
Administrator
Administrator

Re: Can't connect to Azure Dev Ops

Hello, @naulacambra!

Thank you for posting on the Flow Community Forum! Have you had an opportunity to apply @Linuxcable23‘s recommendation to adapt your Flow? If yes, and you find that solution to be satisfactory, please go ahead and click “Accept as Solution” so that this thread will be marked for other users to easily identify!

Thank you for being an active member of the Flow Community!

-Gabriel
Flow Community Manager

-Gabriel
Microsoft Power Automate Community Manager
Are YOU a member of your local Power Automate User Group?
Fill out This Form to claim your Community User Group Member Badge!
Highlighted
Regular Visitor

Re: Can't connect to Azure Dev Ops

I am now getting a different error message than before. It now displays this message:

{"Message":"Redirect URI (https://global.consent.azure-apim.net/redirect?error=InvalidScope) did not receive an expected state query parameter from the authorization service (Referer: https://us.flow.microsoft.com/manage/environments/0ae46d49-ab2f-4c24-a9a1-4913a4ab9f60/flows/new)."}

 I tried this using Chrome, Edge, and Firefox and get the same result.

Highlighted
Frequent Visitor

Re: Can't connect to Azure Dev Ops

I do have more than one account, a personal account and the work account. And none of them works.

 

Since I had this issues, I've tried with only one the accounts at the same time, on several browsers (Chrome, Edge and Firefox), with and without incognito windows, always with the same result.

 

Specifically, now a new error appears.1-E.PNG

 

 

This is the showing message

{"Message":"Redirect URI (https://global.consent.azure-apim.net/redirect?error=InvalidScope) did not receive an expected state query parameter from the authorization service (Referer: https://login.microsoftonline.com/common/oauth2/authorize?client_id=499b84ac-1321-427f-aa17-267ca6975798&site_id=501454&response_mode=form_post&response_type=code+id_token&redirect_uri=https:%2F%2Fapp.vssps.visualstudio.com%2F_signedin&nonce=acb3ce0a-5e7f-4f44-9612-d50f06120144&state=realm%3Dapp.vssps.visualstudio.com%26reply_to%3Dhttps%253A%252F%252Fapp.vssps.visualstudio.com%252Foauth2%252Fauthorize%253Fclient_id%253D5C79975E-E99A-465C-8F02-E8A833C784B0%2526response_type%253DAssertion%2526redirect_uri%253Dhttps%25253A%25252F%25252Fglobal.consent.azure-apim.net%25252Fredirect%2526scope%253D%25255Bvariables%252528%252527scopes%252527%252529%25255D%2526state%253D5474c658-70ba-497f-96eb-92bb536bbbc0_europe-002%26ht%3D3%26mkt%3Den-GB%26nonce%3Dacb3ce0a-5e7f-4f44-9612-d50f06120144&resource=https:%2F%2Fmanagement.core.windows.net%2F&cid=acb3ce0a-5e7f-4f44-9612-d50f06120144&wsucxt=1&mkt=en-GB)."}

 

Highlighted
Regular Visitor

Re: Can't connect to Azure Dev Ops

I decided to try it connecting again. I have no problem connecting to Dev Ops now.

Highlighted
Frequent Visitor

Re: Can't connect to Azure Dev Ops

Same here. I've tried again, doing the exact same thing, and this time worked.

 

Thanks

View solution in original post

Highlighted
Frequent Visitor

Re: Can't connect to Azure Dev Ops


@naulacambra wrote:

I do have more than one account, a personal account and the work account. And none of them works.

 

Since I had this issues, I've tried with only one the accounts at the same time, on several browsers (Chrome, Edge and Firefox), with and without incognito windows, always with the same result.

 

Specifically, now a new error appears.1-E.PNG

 

 

This is the showing message

{"Message":"Redirect URI (https://global.consent.azure-apim.net/redirect?error=InvalidScope) did not receive an expected state query parameter from the authorization service (Referer: https://login.microsoftonline.com/common/oauth2/authorize?client_id=499b84ac-1321-427f-aa17-267ca6975798&site_id=501454&response_mode=form_post&response_type=code+id_token&redirect_uri=https:%2F%2Fapp.vssps.visualstudio.com%2F_signedin&nonce=acb3ce0a-5e7f-4f44-9612-d50f06120144&state=realm%3Dapp.vssps.visualstudio.com%26reply_to%3Dhttps%253A%252F%252Fapp.vssps.visualstudio.com%252Foauth2%252Fauthorize%253Fclient_id%253D5C79975E-E99A-465C-8F02-E8A833C784B0%2526response_type%253DAssertion%2526redirect_uri%253Dhttps%25253A%25252F%25252Fglobal.consent.azure-apim.net%25252Fredirect%2526scope%253D%25255Bvariables%252528%252527scopes%252527%252529%25255D%2526state%253D5474c658-70ba-497f-96eb-92bb536bbbc0_europe-002%26ht%3D3%26mkt%3Den-GB%26nonce%3Dacb3ce0a-5e7f-4f44-9612-d50f06120144&resource=https:%2F%2Fmanagement.core.windows.net%2F&cid=acb3ce0a-5e7f-4f44-9612-d50f06120144&wsucxt=1&mkt=en-GB)."}

 


yep, same is happening to me for a few months now.

Highlighted
New Member

Re: Can't connect to Azure Dev Ops

I am first time trying to connect and have also the same problem now, anybody else ?

Highlighted
New Member

Re: Can't connect to Azure Dev Ops

Why no response here?

Helpful resources

Announcements
firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Users online (9,277)