cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
GuyBoswell
Advocate II
Advocate II

Can't see all Sharepoint Sites in some flow steps

I have created two sites through MS Teams, Complaints and Reporting

I want to give users a friendly, front end form to register complaints on to a Sharepoint list on the site Complaints

In some cases a complaint will come in by letter, I want to be able to add a scan of the letter to the list item for the complaint record

I can make this work on Reporting site (where I don't want it) but not on Complaints site (where I do want it)

I have tried the following

I have found several tutorials, alll describing basically the same process, to add attachements from a form to a list

I make a new list on both the Complaints site and the Reporting site, called UploadTest with fields Title (as added by default to new lists), Where, When and Who

I make a new Forms for Excel in Documents on both sites, both called UploadTest, both with five questions - 1. Title, 2. Where, 3. When, 4. Who (these four all short text) and 5. Question which is file upload with maximum three files.  Question is the default name given when you add a new question and therefore used when as the folder name when it creates /Apps/Microsoft Forms/UploadTest/Question so I left that as it is for simplicity.

I find the form IDs from the share URLs for each form.

In Power Automate I use the template Record Form Responses in Sharepoint.  This all works fine using either the Complaints list and form or the Reporting list and form.  In the Create Item list both sites appear in the drop down for Site Address and the lists both appear in the drop down for List Name once the appropriate site is selected

I add a Parse JSON step to get the file name

I add a Sharepoint Get file content using path step.  THIS IS WHERE THE PROBLEM STARTS

In the drop down list for Site Address I can see the Reporting site and a few others but I cannot see the Complaints site (and several others that are offered in the earlier drop down)

I can finish the flow off for the Reporting site and it all works fine but no amount of cajoling of the flow will let me do the same on the Complaints site

I have found solutions that refer to special characters in URLs being a problem but my site names are simply the words, Complaints and Reporting.

Any suggestions please?  Thank you for all your help.

Guy

4 REPLIES 4
jinivthakkar
Super User
Super User

@GuyBoswell you can manually type the site name using custom value.

 

--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

You can but it doesn't work. You get an error message when you try to save.

Although I created both sites as teams one has a url .../Teams/Complaints , the other is .../Sites/Reporting.  Checking which other sites show in the drop down this seems to be the problem

jinivthakkar
Super User
Super User

@GuyBoswell just try and readding the action or try creating another flow, it has to work.

You would think so wouldn't ou, but no, it doesn't work

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,735)