cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Cannot connect to Sharepoint 2013 with Power Automate using On-Premises Gateway

 Hi,

 

I am unable to connect with my on-premises gateway using Power Automate to SharePoint 2013. To test if the gateway works, I used Power BI to pull the data into a table dashboard to verify it works and it does.

 

When I create the flow, I make sure I add a new connection and switch to / connect to the gateway. Also, when I go to the gateways tab in Power Automate, my gateway is listed there. nevertheless, I cannot get the URL to work. I also am sure the URL is correct and truncate the part of the URL at the end that causes errors. I am attempting to enter a custom value when I do this. See attached images.gateway1.pnggateway2.png

 

If I cannot use a gateway to connect PA to SharePoint 2013 lists, please tell me if I can export the list data from PowerBI and "mirror" or copy the list data into SharePoint Online to setup the flow I want.

 

Also if someone knows how I can see what services / environments my gateway is connected to from the On-premises gateway app on my PC let me know. As you can see in my image, the status screen does not show anything other than the gateway version number.

4 REPLIES 4
Highlighted
Super User III
Super User III

Re: Cannot connect to Sharepoint 2013 with Power Automate using On-Premises Gateway

Hi @jstfmc1 

 

Could you try setting the main root site address only (https://yoursharepoint.com) and see any lists are loading under the dropdown box of List Name.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

Power Automate Video Tutorials
Highlighted
Frequent Visitor

Re: Cannot connect to Sharepoint 2013 with Power Automate using On-Premises Gateway

I did that and it still cannot find the site.

Highlighted
Super User III
Super User III

Re: Cannot connect to Sharepoint 2013 with Power Automate using On-Premises Gateway

Hi @jstfmc1 

 

Thanks for your reply. Generally once you installed the gateway you should be able to connect it. It's difficult to analyse without checking via a screen share.

 

 

 

 



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

Power Automate Video Tutorials
Highlighted
Frequent Visitor

Re: Cannot connect to Sharepoint 2013 with Power Automate using On-Premises Gateway

How can I check if my on-prem gateway is only setup for Power BI (I think it is called personal)?

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Tech Marathon

Maratón de Soluciones de Negocio Microsoft

Una semana de contenido con +100 sesiones educativas, consultorios, +10 workshops Premium, Hackaton, EXPO, Networking Hall y mucho más!

Top Kudoed Authors
Users online (6,145)