cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
itshouldwork
New Member

Cannot select table when connecting to an Excel file

I try to connect responsed collected in Forms to a visualisation in Power BI. To do this, it seems one has to use Power Automate. I tried to build the following flow but cannot select the correct "table" of the Excel file. The drop-down menue should list all sheets of the table. If entering custom values, I receive the below mentiones error. What am I doing wrong? Thanks for any hints!

 

Flow.png

 
 
 

The dynamic operation request to API 'excelonlinebusiness' operation 'GetTable' failed with status code 'NotFound'. This may indicate invalid input parameters. Error response: { "status": 404, "message": "The requested resource doesn't exist. clientRequestId: (…) serviceRequestId: (…)", "error": { "message": "The requested resource doesn't exist." }, "source": "excelonline-we.azconn-we.p.azurewebsites.net" }

1 ACCEPTED SOLUTION

Accepted Solutions
itshouldwork
New Member

It seems to have been a bugg. As soon as I connected to the origianl Excel file downloaded from Microsoft Froms (instead of an own Excel file which I used for testing), it worked.

View solution in original post

3 REPLIES 3
Brad_Groux
Super User II
Super User II

Please note, that there are multiple Excel connectors with hugely different capabilities: 

Also, you will notice that each has their own extensive list of known issues and limitations:

First you should ensure that you are using the right connector, and that you are working within that connector's known issues and limitations. 

Second, because of these issues and limitations I'd highly recommend that instead of using a spreadsheet, that you'd migrate this workload to a SharePoint list if possible. SharePoint has a far more complete API, has more than 10x the API call limits, and has no file lockout issues like Excel.

With that said, if you want to continue forward with Excel, you should add a Get Tables action (OneDrive)Get Tables action (Business) before the add a row to a table step.

If this reply answers your question or solves your issue, please ACCEPT AS SOLUTION ☑️. If you find this reply helpful, please consider giving it a LIKE.

itshouldwork
New Member

It seems to have been a bugg. As soon as I connected to the origianl Excel file downloaded from Microsoft Froms (instead of an own Excel file which I used for testing), it worked.

View solution in original post

 

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Carousel

Sign up for our May 4th event!

May the fourth be with you, join us online!

MSFTBizAppsLaunchEvent

Experience what’s next for Power Virtual Agents

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Users online (60,752)