cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ishraqiyun77
Helper IV
Helper IV

Changing custom connector name

I made a custom connector for QuickBooks Online so we can integrate it with Dynamics 365. 

I started making the QBO connector using their built in "Sandbox" environment so I could isolate my testing from the production environment.  Thus, it is called "QuickBooks Online - Sandbox".

I've since come to find out that if I make a custom connector called "QuickBooks Online - Production" and want to switch my Flows to using it, I basically have to rebuild the Flows where it uses the connector.

  • You can't swap and existing Action for another
  • If you do, it deletes all of the Dynamic content and Expressions in it
  • Copy to my clipboard (Preview) doesn't work 99% of the time
  • Or you can copy the Flow (oh wait, no you can't if it is in a solution) and have the burden of maintaining two sets of identical Flows and redoing all of your work

Really, really, really poor design decision on the part of Microsoft.

At any rate, I decided the simplest solution is to just use the same connector and when we want to use it for production, change the URL information in the various actions in the custom connectors to point at the production environment... (and cross my fingers this doesn't delete all the information in Flows).

All that being said, it is kind of confusing because I am apparently stuck with the name "QuickBooks Online - Sandbox" and just want to change it to "QuickBooks Online".

  1. Is there a way to change the name?
  2. If I change the request body in custom connector, is it going to erase all of the information in my Flows where it uses those corresponding actions?
1 REPLY 1
abm
Super User
Super User

Hi @ishraqiyun77 

 

I found the hard way recently and I can see your frustrations.  You can't add the custom connector as part of your solution and deploy it. Believe one of the reason could be is the endpoint can be different for each environments of your custom API. 

 

Following are the steps I used to deploy my custom connector.

 

1. Created my customer connector under my dev environment. 

 

2. Once the build is finished and tested then  click the download

image.png

 

3. Change your environment from dev to test or production. Click custom connector > New custom connector > Import an OpenAPi file.

image.png

 

4. This does import the settings from your Dev environment. Review each settings, update the client id & secret key if using OAuth 2.0 

 

Not the best way but it saves quite a lot of time to enter all the details again.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blogPower Automate Video Tutorials

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Users online (1,898)