cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Advocate I
Advocate I

Connect to custom on-premises APIs using data gateway - Windows Authentication

 

My on-premise api is made with windows authentication.

 

When i choose "Windows Authentication", it reverts everytime to "No Authentication"

 

Is there someone who could explain how to properly parameterize this kind of connection ?

 

Sans titre.png

 

 

 

2 REPLIES 2
Community Support
Community Support

Hi dasimon,

 

Have you seen this blog on “Connect to custom on-premises APIs using data gateway”:
https://flow.microsoft.com/en-us/blog/on-premise-apis/

 

Please take this blog for a reference and try again with it.

 

Best regards,
Mabel Mao

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Mabel,

 

I have indeed successfully tested the case where the API is without authentication using this post, but it is not indicated how to configure internal APIs with Windows authentication.

Moreover, when we choose windows authentication, and we click on continue, the choice becomes no authentication again. It's the same behavior for Basic authentication.

 

best regards,

 

David

Helpful resources

Announcements
PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Top Kudoed Authors
Users online (6,031)