cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Regular Visitor

Connect to excel generated by FORMS - Lives in Sharepoint Docs

Hello,

 

I have an excel table that lives in a SharePoint site. Using the Get a Row connection, I can navigate to the folder, but then I cannot find my table.  

 

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Community Support
Community Support

Hi @KatieL1,

 

You could use the Get tables action to confirm the Excel file whether has a table in it.

If it has, please close the Flow and then reopen it.

If it hasn't, you could refer to the link provided by  @efialttes. Create a table in it and try it again.

If the two try both not work, please share the screenshots of the Excel table and Flow configuration, we could help you further.

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
Dual Super User III
Dual Super User III

Hi!
Does the ID correspond to a Sharepoint item? If so, does it come from the trigger? Is the source a 'Get item' action block? Are you inside an Apply to each iterating over a 'Get items' output?
Need more informaton context
Thanx!


Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



View solution in original post

6 REPLIES 6
Highlighted
Dual Super User III
Dual Super User III

Hi!

You are using Excel Online (business) connector 'Get a row' action block, right?

https://docs.microsoft.com/en-us/connectors/excelonlinebusiness/#get-a-row

Also, you added the table by following these steps, right?

https://support.office.com/en-us/article/create-and-format-tables-e81aa349-b006-4f8a-9806-5af9df0ac6...

 

If you created the table after adding the action block to the flow, it will not be displayed. My suggestion is to add a new 'Get a row' action block

Hope this helps



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Highlighted
Community Support
Community Support

Hi @KatieL1,

 

You could use the Get tables action to confirm the Excel file whether has a table in it.

If it has, please close the Flow and then reopen it.

If it hasn't, you could refer to the link provided by  @efialttes. Create a table in it and try it again.

If the two try both not work, please share the screenshots of the Excel table and Flow configuration, we could help you further.

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted

ok, Ive gotten a little further. I can now find my table (created from Forms).

 

Ive chosen ID as my key field since this is unique to each row added. I need to grab content from additional columns unique to the Excel Sheet. But I do not seem to have any dynamic fields for the Key Value

Highlighted
Dual Super User III
Dual Super User III

Hi again!
Well, we are closer to a happy ending, right?Now, let's talk about your new issue. IN order to understand better it, can you share a screenshot from your current flow design? Also if possible, share a second screenshot from the Dynamic content menu, so we can understand better which options you miss there.
THanx for helping to make this comminity great!


Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Highlighted

Flow_get data.pngExcel online_1.png

Highlighted
Dual Super User III
Dual Super User III

Hi!
Does the ID correspond to a Sharepoint item? If so, does it come from the trigger? Is the source a 'Get item' action block? Are you inside an Apply to each iterating over a 'Get items' output?
Need more informaton context
Thanx!


Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Users online (10,397)