cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Copy Email attachment to local file share

I'm having a problem with the "Copy FIle" function used in conjunction with the On-Premises Data Gateway. My intent is to save the email attachment (a PDF) to a local file share:  \\ServerName\Share\Folder\  I've built the Flow, I've added the Gateway, I've installed the On-Premises Data Gateway on a local PC. but every time the Flow runs, I get the error below:

 

{  "status": 400,

  "message": "The character '\"' is not allowed in file paths, remove or replace it before retrying.\r\nclientRequestId: 8150c0a2-c009-459e-a372-28204949332f",

  "source": "filesystem-wus.azconn-wus.p.azurewebsites.net"  }

 

I've tried several different variations of the file paths as shown in the picture below .. but every time, I get the same message. I'm sure I'm missing something, but I can't figure it out and I can't find any reference to this error anywhere on the net. Any help would be appreciated.

 

And just in case it helps with troubleshooting, the "Source URL" message under the Inputs section below is:  

{"Id":"AAMkADBjNjY1ZTBmLWMyNzUtNGRmOC1hNzA4LTJiYjM4ZTEyODVhNwBGAAAAAABALLQR3VISQbN_rcjITYc-BwAfx7vZvO5aRJMTbySGvJWUAAAA0wXcAABlZeWyZznAS7VuF6SH-bWCAABWsGIVAAABEgAQANXm46Ym1LZGq7xNyzwbGZM=","Name":"TestDocument.pdf","ContentBytes":null,"ContentType":"application/pdf","Size":35125}

 

FlowandError.jpgGateway.jpg

1 REPLY 1
Highlighted
Community Support
Community Support

Re: Copy Email attachment to local file share

Hi @ BayouJeff,

 

 

How do you configure the Root folder in your connection?

 

I have made a test on my side and have created a connection as below:

 

1.png

The Root path is “C:\Users\Administrator\Desktop\1\2"

And if I would save the file in the path is “C:\Users\Administrator\Desktop\1\2", I could add a "Create file" action to create the file, and I could choose the file path in the "Folder Path" field of the "Create file" action.

 

 

You could refer to  link below to see the similar post:

https://powerusers.microsoft.com/t5/Connecting-To-Data/Problem-connecting-to-File-System-in-Flow/m-p...

 

Please take a try to use the "Create file" action instead of the "Copy file" action and let me know if it helps.

 

 

 

 

Regards,
Alice Zhang

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Upcoming Events

Experience what’s next for Power Automate

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Top Kudoed Authors
Users online (4,702)