cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sundayDriver
Advocate IV
Advocate IV

Cosmos DB fail to create document properties

Hi,

I'm trying to create a flow that inserts or updates a document. The JSON formats that I have tried are:

{

 "id":"ID",

 "label": "LABEL",

 "prop1": "PROP1"

}

 

{

 "id":"ID",

 "label": "LABEL",

"properties":{

  "prop1": {

   "value": "PROP1"

   }

 }

}

 

In none of these cases I've managed to see in the cosmos DB the property prop1.

FYI the cosmosDB is using Gremlin.

 

Thank you,

4 REPLIES 4
sundayDriver
Advocate IV
Advocate IV

I cannot also add edges on the graph. Am I using the right connector?

Thank you,

v-xida-msft
Community Support
Community Support

 Hi @sundayDriver,

 

Do you use Azure Cosmos DB connector in your flow?

Could you please share a screenshot of your flow’s configuration?

Further, could you view the document that you have created in Azure Cosmos DB?

I have made a test on my side and the flow works well, but I could not view it in Azure Cosmos DB:4.JPG

 

If you would like to see the documents of Azure Cosmos DB, you could add “Get a document” action or “Get all documents” action in your flow.5.JPG

 

More details about Documents of Azure Cosmos DB, please check the following document:

Documents of Azure Cosmos DB

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @v-xida-msft,

Thank you for your help. Here are some screenshots when I try to add an edge:

image.pngimage.png

And when I try to add a property:

image.pngimage.png

The property cannot be seen here.

Thank you,

I have the same problem. If I create a new Cosmos DB element via Flow, the element is created, but the properties are not stored within it. I used the example GraphSON from https://docs.microsoft.com/en-us/azure/cosmos-db/gremlin-support as the Document-code in Flow-editor. However, FirstName, LastName and Age are not stored in the element. Am I doing something wrong? Are there any workarounds for this issue?

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MSFTBizAppsLaunchEvent

Experience what’s next for Power Virtual Agents

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Users online (46,447)