cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Create From Azure service (Preview) -> LogicApp

Hi Community,

 

I'm wondering whether anybody has come across a similar issue when creating a custom connector for LogicApp using 'Create From Azure service' option or exporting OpenAPI for LogicApp directly from Azure portal. 

 

In Power Automate portal I had connected to my LogicApp that has got 'HTTP request' trigger and got API definition pulled through including the following artefacts:

Host

Base URL

Action for manual-invoke

Method: GET

Query Parameters: api-version, sp, sv, sig, 

 

API itself has no authentication.

 

When I try to test it I get the following response:

{
"error": {
"code": "AuthorizationFailed",
"message": "You do not have permissions to perform action 'run' on scope '/triggers/manual/paths/invoke/99/'. Verify you are making the request with the appropriate HTTP method. See http://aka.ms/logic-trigger for details."
}
}

 

I'm not an app developer so any pointers on how I can address this issue would be much appreciated.

 

Many Thanks,

 

WJ

 

1 REPLY 1
Highlighted
Frequent Visitor

Re: Create From Azure service (Preview) -> LogicApp

I had the same issue. The problem is that the pv query string parameter contains the wrong value.

Do not copy paste the encoded value such as %2F but use actual /.

The value in my case was /triggers/request/path

Helpful resources

Announcements
firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Users online (8,230)