cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Osmund
Regular Visitor

Crm instance does not have security roles defined for you.

Hi, I´m trying to create a flow executing when updating a Dynamics CRM opportunity.

I can connect to our CRM 365 instance in the trigger, but when the flow runs I get this error:

OUTPUTS
  • Headers
    { "Pragma": "no-cache", "x-ms-request-id": "e6e4789b-67b0-48ef-ac5b-427856f8e18c", "Cache-Control": "no-cache", "Date": "Fri, 09 Dec 2016 21:35:29 GMT", "Set-Cookie": "ARRAffinity=60399012fd538cc9e9434dab83cc998989a70dd2f847ebc7117eb704b9c942d6;Path=/;Domain=127.0.0.1", "Server": "Microsoft-IIS/8.0,Microsoft-HTTPAPI/2.0", "X-AspNet-Version": "4.0.30319", "X-Powered-By": "ASP.NET", "Content-Length": "106", "Content-Type": "application/json; charset=utf-8", "Expires": "-1" }
  • Body
    { "status": 401, "message": "Crm instance does not have security roles defined for you.", "source": "127.0.0.1" }

I´m not a CRM guy, but I have enought access in CRM to create and read all opportunities.

9 REPLIES 9
kartikraop
Power Automate
Power Automate

Another user reported same error just a few minutes back. We are following up with the CRM connector / service owners to get more details on the root cause and required action if any from the user to fix it. Will share more details as soon as i have it.

Hi @Osmund,

 

Can you please check your flow my connections (Top right hand side settings > connections) of your CRM?

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blogPower Automate Video Tutorials
Osmund
Regular Visitor

It says I´m connected.

crm connection.jpg

abm
Super User III
Super User III

Hi @Osmund,

 

Thanks for your reply. Of course it is connected. Can you do the following:

 

1. Re-Enter your credentials. I don't think flow allows to do this. Probably you need to recreate your connection again. Try and see if it fails again or not.

 

2. If Step 1 fails then try a different user credentails.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blogPower Automate Video Tutorials
Osmund
Regular Visitor

Did 1 and 2 and still same issue.

abm
Super User III
Super User III

Hi @Osmund,

 

Let me try to recreate it. Will update soon.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blogPower Automate Video Tutorials
abm
Super User III
Super User III

Hi @Osmund,

 

Unfortunately I couldn't replicate your issue. Please see below.

 

My Flow

 

o1.png

 

Flow Test Result

 

=

o2.png

 

Also I tried to deactivate one record by close as won. That worked as well.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blogPower Automate Video Tutorials
dargue
Frequent Visitor

Hi @Osmund. I am having the same issue. Did you ever get this resolved?

Thanks

I'm having the same issue right now, a week or two ago everything was fine. Does anyone know?

Helpful resources

Announcements
MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (86,582)