cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Regular Visitor

Custom Connector Path setting

Hi.

 

I would like to make an custom connector on Power Automate

While I'm creating it, I cannot resolve a problem

 

When I make connectors using its global ID, the result says that the page is not found (404 error)

 

For example, 

When I make connector

I. GET https://xxxxxx.xxxx/items?page&per_page

( page & per_page parameters by query)

it works.

 

However,

II. GET https://xxxxxx.xxxx/items/{id}

({id} parameters by path)

it is 404 errors.

 

This II URL does work when I test at postman.

 

In order to find out the problem, I want to know general information how to set up path on setting URL.

 

If need more information, please tell me.

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions


@shalowsoup wrote:

thank you for your replay, and sorry to reply you late

 

Following 7 pictures are screenshot of the issue

 

Success pattern shots are the connector using query pattern (which I typed "/partner.json?page&per_page")

Then, it's parameter goes to query area, and the test is suceeded.

 

But, then, when I make a connector using path pattern ( which I typed "/partner.json/{id}")

Then, it's parameter goes to path, but test is failure.

 

Last shot is the one when I checked swaggler page. I fould that there is a warning about the pattern with Path. It says that I need to define whether it is path or operational level.

 

Anyway, I haven't read any article how to set path for custom connector. If I can read, and it must be easy to find out how to set it up.

Is there anyone who knows how to set up path in custom connector?

 

Thanks


You did not include any screenshots. If you could provide an expanded screenshot of your Flow and steps, your Flow run history, and of any detailed error messages you're receiving we could likely better assist you. Also, for the best results, you may want to review How to write a good forum post.

👨🏻‍💻 If this reply answers your question or solves your issue, please ACCEPT AS SOLUTION ☑️. If you find this reply helpful, please consider giving it a LIKE 👍.

View solution in original post

3 REPLIES 3
Community Support
Community Support

Hi @shalowsoup ,

 

Would you please share a screenshot of the error message?

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

thank you for your replay, and sorry to reply you late

 

Following 7 pictures are screenshot of the issue

 

Success pattern shots are the connector using query pattern (which I typed "/partner.json?page&per_page")

Then, it's parameter goes to query area, and the test is suceeded.

 

But, then, when I make a connector using path pattern ( which I typed "/partner.json/{id}")

Then, it's parameter goes to path, but test is failure.

 

Last shot is the one when I checked swaggler page. I fould that there is a warning about the pattern with Path. It says that I need to define whether it is path or operational level.

 

Anyway, I haven't read any article how to set path for custom connector. If I can read, and it must be easy to find out how to set it up.

Is there anyone who knows how to set up path in custom connector?

 

Thanks


@shalowsoup wrote:

thank you for your replay, and sorry to reply you late

 

Following 7 pictures are screenshot of the issue

 

Success pattern shots are the connector using query pattern (which I typed "/partner.json?page&per_page")

Then, it's parameter goes to query area, and the test is suceeded.

 

But, then, when I make a connector using path pattern ( which I typed "/partner.json/{id}")

Then, it's parameter goes to path, but test is failure.

 

Last shot is the one when I checked swaggler page. I fould that there is a warning about the pattern with Path. It says that I need to define whether it is path or operational level.

 

Anyway, I haven't read any article how to set path for custom connector. If I can read, and it must be easy to find out how to set it up.

Is there anyone who knows how to set up path in custom connector?

 

Thanks


You did not include any screenshots. If you could provide an expanded screenshot of your Flow and steps, your Flow run history, and of any detailed error messages you're receiving we could likely better assist you. Also, for the best results, you may want to review How to write a good forum post.

👨🏻‍💻 If this reply answers your question or solves your issue, please ACCEPT AS SOLUTION ☑️. If you find this reply helpful, please consider giving it a LIKE 👍.

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Users online (3,431)