cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Padmaja
Level: Powered On

Custom connector created from postman collection is not working

Hi Team,

 

We are trying to build custom connector for flow using Postman collection to consume a cistom API. We referred the below url for building the connector: https://docs.microsoft.com/en-us/connectors/custom-connectors/define-postman-collection

 

We have tested the API and made sure that it works from postman before exporting the postman collection. When we created the custom connector by using the exported postman collection, the operations never work and report the below error :

 

Request failed. Please try again in a few minutes.

 

The web API is using API key authentication, and we did supplied the correct key while testing the API methods.

We are facing the same exact issue mentioned in the post here.

 

Can someone help here with your inputs to troubleshoot it further.

 

Thank you.

 

 

2 REPLIES 2
Community Support Team
Community Support Team

Re: Custom connector created from postman collection is not working

Hi @Padmaja,

 

Do you specify the API Key as the Authentication type of your custom connector which is created from your Postman collection?

 

If you use the API Key as the Authentication type of your custom connector which is created from your Postman collection, it is not recommended to test the connector immediately after you create it. It can take a few minutes until the connector is ready to connect to the API.

 

More details about testing custom connector which is created from your Postman collection, please check the following article:

Test the connector within Microsoft Flow

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Padmaja
Level: Powered On

Re: Custom connector created from postman collection is not working

Hi Kris,

 

Yes, we did sepcified API Key as the authentication mechanism while creating the custom connector.

 

Have gone through the link provided for testing the flow, and followed the same steps, still we get the error from flow saying that Request failed. Any thoughts what else we can check to see to get rid of this error.

 

Thanks for all the inputs.

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Watch the event on demand for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 Release Wave 2 Plan

Power Platform 2019 Release Wave 2 Plan

Features releasing from October 2019 through March 2020.

thirdimage

Flow Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Flow Community Video Gallery!

Users Online
Currently online: 60 members 3,503 guests
Please welcome our newest community members: