cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Data Source wont load for shared users

I have created an app using on-premise sharepoint list which works for me but when I share it with others the data wont load and "An error has occurred" message appears at the top.

Any data that is not part of a Data Source display normally.

I have replicated with a template app connected to oneDrive with the same results.

I have share the Gateway, Sharepoint and App to the highest permissions with no change.

Did the same for the oneDrive app.

Can anyone think what I could be missing?

These are my first apps which work perfectly for me but noone else.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Frequent Visitor

Re: Data Source wont load for shared users

SELF SOLVED

 

It was a rookie mistake on my part but may help others.

 

When PowerApps asked for permission to access SharePoint, we had the other user logged in with their Microsoft email address not their AD account credentials.

As we use AD and not AzureAD the email login had no permissions to SharePoint but the AD account did.

View solution in original post

4 REPLIES 4
Highlighted
Community Support
Community Support

Re: Data Source wont load for shared users

Hi @Wade_,

 

Could you please share more details about the error message?

 

I could make a test with a on-premise sharepoint list on my side.

 

Please share more details about the error message so we would try to provide a proper workaround for you.

 

Best regards,

Alice

 

Highlighted
Frequent Visitor

Re: Data Source wont load for shared users

Hi @v-yuazh-msft,

 

I have created an app that links to a sharepoint list on my sharepoint site and set the share permissions on the site and list for another user from edit to full control trying to solve this issue with no change.

I have an on-premise gateway on the sharepoint server which I have shared with the same user.

The app itself has also been shared with the same user and permission set as high as possible again attempting to solve the issue.

 

When I use the app everything works.

When the other user opens the app the information that is not data from the sharepoint list loads but the sharepoint data doesn't and the red banner error at the top states "An Error Occurred on the Server".

 

I have tried an app with no external data and it shares correctly.

 

I have used a template with external data from one drive which has the same error as the sharepoint app.

 

Any help is much appreciated.

Highlighted
Frequent Visitor

Re: Data Source wont load for shared users

Hi Alice
Have you had any luck testing this issue?
Highlighted
Frequent Visitor

Re: Data Source wont load for shared users

SELF SOLVED

 

It was a rookie mistake on my part but may help others.

 

When PowerApps asked for permission to access SharePoint, we had the other user logged in with their Microsoft email address not their AD account credentials.

As we use AD and not AzureAD the email login had no permissions to SharePoint but the AD account did.

View solution in original post

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (7,098)