cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Regular Visitor

Data cannot be processed with new custom connector

Hello, I'm trying creating a custom connector.

 

When I make "GET" connector with proper URL, ( which was working collectively in Postman)

 

However, when I use on Power Automate, it becomes an error with a following message.

 

InvalidTemplate. Unable to process template language expressions in action 'test' inputs at line '1' and column '2757': 'The template language expression 'json(decodeBase64(triggerOutputs().headers['X-MS-APIM-Tokens']))['$connections']['xxxxxxxxxxxxxxx']['connectionId']' cannot be evaluated because property 'xxxxxxxxxxxxxxx' doesn't exist, available properties are 'xxxxxxxxyyyyyyy'. Please see https://aka.ms/logicexpressions for usage details.'.

 

What should I look up to solve this error?

 

1 ACCEPTED SOLUTION

Accepted Solutions
Dual Super User II
Dual Super User II

Hi @shalowsoup 

 

Is this flow being triggered from a Power Apps control? If so, this is a very common error and can be resolved by removing the flow from the power apps control and then add it again over there. 

 

If not, can you share more details on the trigger type so that we can better understand the issue and help you with this? 

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

2 REPLIES 2
Dual Super User II
Dual Super User II

Hi @shalowsoup 

 

Is this flow being triggered from a Power Apps control? If so, this is a very common error and can be resolved by removing the flow from the power apps control and then add it again over there. 

 

If not, can you share more details on the trigger type so that we can better understand the issue and help you with this? 

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

When I tried, then it solved. Thank you very much.

 

Helpful resources

Announcements
PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Kudoed Authors
Users online (3,597)