cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
wiredupjax
Resolver I
Resolver I

Defect in Jotform, Power Automate & SharePoint

I'm using Jotform to conduct surveys.  That survey data is coming over into a SharePoint list via Power Automate.

 

Even though I have selected "text" for the fields, I'm receiving HTML <br>'s after the Jotform answers.  This is preventing me from managing the data once in SharePoint.

 

Adding HTML.jpg

 

Here is the PA flow:

powerauto.jpg

 

Below shows the spaces in the text:

spaces.jpg

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @wiredupjax,

 

Yes, if it is a Yes/No type, it will have the same issue. If it is a simple choice type, it will not has additional '\n'.

 

So, as a workaround, you could use the simple choice, set the options to Yes/No:Annotation 2020-05-19 140431.jpg

Or you could use the uriComponent() function to convert the '\n' into URI code '%0A', then use replace() function to remove the '%0A', then use the decodeUriComponent() function convert it back:

decodeUriComponent(replace(uriComponent(triggerBody()?['QuestionName']),'%0A',''))

Annotation 2020-05-19 140834.jpg

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

View solution in original post

5 REPLIES 5
ScottShearer
Super User
Super User

@wiredupjax 

Try the following - replace the values in your Create item action with following expression for each column:

first(split([reference to the value from Jotform from Dynamic props], '\n'))

So, for each column in the SharePoint list, you'll enter the expression above with a reference to the value to be inserted from Dynamic props.

 

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

@ScottShearer Thank you for the response.

 

I created the expression as you described, however I am still getting the \n

 

See the flow and flow output

 

flow.jpgflowoutput.jpg

 

 

Hi @wiredupjax,

 

I tried to produce a JotForm, and create an item in SharePoint list, but '\n' doesn't appear, I guess the root cause is on the JotForm, when you submit the JotForm, did you type any "Enter"?

Annotation 2020-05-19 093149.jpg

 

Annotation 2020-05-19 093226.jpg

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@v-litu-msft 


Try to create a question as Yes/No -- not as a single choice but the Yes/No and see if it comes across with the \n

Hi @wiredupjax,

 

Yes, if it is a Yes/No type, it will have the same issue. If it is a simple choice type, it will not has additional '\n'.

 

So, as a workaround, you could use the simple choice, set the options to Yes/No:Annotation 2020-05-19 140431.jpg

Or you could use the uriComponent() function to convert the '\n' into URI code '%0A', then use replace() function to remove the '%0A', then use the decodeUriComponent() function convert it back:

decodeUriComponent(replace(uriComponent(triggerBody()?['QuestionName']),'%0A',''))

Annotation 2020-05-19 140834.jpg

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,818)