cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Rosie Helper I
Helper I

Dynamic content missing for a document library

Hello,

I have a site set up which contains a Library template.  I have two folders that have been created with the Library template.

When I use the flow to connect to the first library all the library properties are available in the dynamic content list.

Bur when I change the flow to connect to the second library there are some library properties missing at the exact point of the flow where I need them to be.

I can't understand what the difference is, can anyone please advise?

 Missing Notify field.JPGInitialiseVariable-NotifyEmailList.JPG

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support
Community Support

Re: Dynamic content missing for a document library

Hi @Rosie ,

 

Please check if there is any difference between the output of the trigger in the two flow when they runs.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

 

View solution in original post

9 REPLIES 9
Community Support
Community Support

Re: Dynamic content missing for a document library

Hi @Rosie ,

 

If the two fields are new created fields?

Could you please take a try to create a new flow now to see if the issue still exists?

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Rosie Helper I
Helper I

Re: Dynamic content missing for a document library

Hello,

The two fields aren't newly created.  The two fields 'Notify' and 'Approver' appear if a different library is selected.

I tried creating a new flow from scratch and had the same problem with the specific library.

The two fields also appear in out parts of the flow but just not for the Apply to each control, please see image attached.NotifyVisibleInFlow.JPG

Rosie Helper I
Helper I

Re: Dynamic content missing for a document library

Hello,

I have just tried creating a standard document library and setting the default content type and the two fields appear in the Flow.

There seems to be an issue with these two fields showing in the flow only when a Library is created from a template.

The template is very basic, it just has versioning turned on.

 

Thanks

Rosie

Dual Super User
Dual Super User

Re: Dynamic content missing for a document library

@Rosie 

 

Go to expression Tab and enter ?

Then switch over to dynamic content and see if you see all dynamic content options

 

--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

 

Rosie Helper I
Helper I

Re: Dynamic content missing for a document library

Hello @RezaDorrani,

That didn't make any difference.

Cheers

Rosie

Community Support
Community Support

Re: Dynamic content missing for a document library

Hi @Rosie ,

 

Please check if there is any difference between the output of the trigger in the two flow when they runs.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

 

View solution in original post

Rosie Helper I
Helper I

Re: Dynamic content missing for a document library

Hello,

No the two flows had the same output.

 

Thanks

Rosie

notj Post Patron
Post Patron

Re: Dynamic content missing for a document library

@Rosie I'm having the same issue with my own Flow. Did you ever resolve this?

Rosie Helper I
Helper I

Re: Dynamic content missing for a document library

Hello,

No I didn't.  I got around it by creating a document library without the template and then making the settings the same, then all the fields came through in flow.  Bit annoying and not efficient as I will need to create more of these.

There does seem to be something not working quite right with Sharepoint templates and Flow.

 

Cheers

Rosie

 

Helpful resources

Announcements
firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Automate Community!

firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Community Summit North America

The top training and networking event across the globe for Microsoft Business Applications

Users online (5,722)