cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
KMac1980
Level: Powered On

Flow not sending emails when a user submits multiple SharePoint surveys

One of our business areas created a flow that sends an email to Network Support when a new SharePoint Survey is submitted and it has been working fine, except when a user submits multiple tickets back to back. The first email will send, but no other emails will send afterwards. 

 

I know there are limitations on runs back to back, but it should just delay sending out the other emails correct? We verified that emails were never sent, even delayed. 

spsurveyflow.PNG

Is there an issue with Power Automate connecting to SharePoint Surveys? (I know they should be using Forms or a SP list with Power Apps, but our team doesn't have time to build it for them yet, and they aren't comfortable building anything new)

2 REPLIES 2
Community Support Team
Community Support Team

Re: Flow not sending emails when a user submits multiple SharePoint surveys

Hi @KMac1980,

 

How many tickets do you submit at one time? I tested your Flow on my side, and it could run multiple times in a short time.Annotation 2020-01-14 101544.png

There is no issue with Power Automate connecting to SharePoint Surveys. 

You mentioned the user when a user submits multiple tickets back to back, the first email will send, but no other emails will send afterward. Are you sure the first email is sent by the Flow that the user executes? I assume the email may be sent by other Flow, and the connection of the user is not valid. Please make sure it and let me know, thanks.

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

KMac1980
Level: Powered On

Re: Flow not sending emails when a user submits multiple SharePoint surveys

@v-litu-msft  the user stated she submittted 4 tickets(surveys) one after another. She got an email saying her support ticket was created from her first submission, the following 3 submissions, no emails were received regarding her ticket. The associate that created the flow checked the shared mailbox that receives the emails/creates the ticket in Service Manager and only the first submission was received by that mailbox, no other emails were received from her. She has had several instances of this happening.

 

It's all very strange. 

Helpful resources

Announcements
firstImage

Power Platform Online Conference

Join us for the first ever Power Platform Online Conference!

firstImage

Coming Soon: T-shirt Design Contest

Keep your eyes open for our upcoming T-shirt design contest!

firstImage

Incoming: New and improved badges!

Look out for new contribution recognition badges coming SOON!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Top Solution Authors
Top Kudoed Authors
Users online (6,301)