cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
james-matson
New Member

Flow - populate word template not working - Error executing the api '/api/templates/schema'

I have created a word template (as .docx) with a single plain text control. 

 

I have saved this in OneDrive. But when I try to use the word connector to update the text control, the following error occurs in the flow step: 

 

2019-12-09 10_27_40-FSD - Template.docx - Word.png2019-12-09 10_27_26-Edit your flow _ Microsoft Power Automate.png

6 REPLIES 6
Krishna92
Microsoft
Microsoft

@james-matson 

 

I think you have not selected the right template when creating the word document.

Please check the thread below for reference regarding the same issue and let me know if that helps.

 

https://powerusers.microsoft.com/t5/Connecting-To-Data/FLOW-Populate-Word-Template-Error-executing-t...

 

If this information helps you, please hit the like button and mark the solution as resolved, so that it will help other users in future.

I am using the Developer tab to create the property - is that not correct? See below. It's plain text.

 

2019-12-09 13_40_55-FSD - Template.docx - Word.png

@JamesM 

 

That's the right way to achieve the scenario not sure where it is failing.

Could you please try removing the Word action card and re-add it again to check if that helps.

 

v-bacao-msft
Community Support
Community Support

 

Hi @james-matson ,

 

Did you encounter this error while configuring Populate a Microsoft Word template action?

When configuring the required parameters of this action, please configure it through the drop-down option or File browse. It is not recommended to manually enter the parameter values.

Also, please refer to this similar thread and see if it helps:

https://powerusers.microsoft.com/t5/Building-Flows/Error-Populating-a-word-template/m-p/416304#M4792...

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi all, removing and re-adding the action solved this issue. The flow ran successfully, but when I check the template, the plain text control value remains unchanged. No errors were encountered. Perhaps I'm not understanding how to do this properly? The flow even correctly makes a new copy of the document in OneDrive for Business, but the copied file also remains unchanged (text value is still the template default). 

 

2019-12-10 09_16_01-Run History _ Microsoft Power Automate.png

 

Hi @JamesM ,

 

Here is no need to configure the Get file content action, you just need to configure Create file action using the Microsoft Word Document output by Populate a Microsoft Word template.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Top Kudoed Authors
Users online (1,143)