cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ricardoj
Regular Visitor

Flow stopped working after months. 403 Error with Permissions on Excel Online file.

Hello there. Flow was working perfectly for months and suddenly gave a permissions error on the Excel file it uses. Excel is hosted on OneDrive for Business. 

 

Here is the error:

{
"status": 403,
"message": "The user doesn't have permissions to open the workbook in edit mode. Please fix your permissions and try again.\r\nclientRequestId: e920ec8c-d342-45a5-9b9c-76ecb5907085",
"error": {
"message": "The user doesn't have permissions to open the workbook in edit mode. Please fix your permissions and try again."
},
"source": "excelonline-cus.azconn-cus.p.azurewebsites.net"
}

 

What can I do? Thanks in advance for any help.

1 ACCEPTED SOLUTION

Accepted Solutions
ricardoj
Regular Visitor

So it is now working again (one detail I noticed was that it was now saying "Bad Gateway" in the Flow Excel Online connector.

 

Here is what I did, but I don't know if it was just a temporal thing and it fixed itself, or if what I did helped:

 

I created a new Flow with all the same elements (Mailbox access, OneDrive for Business, and Excel Online). There was a template that use all the 3. I use this template to create a new flow and it asked me again for permissions.  I was now able in this new flow to access the tables in my Excel file.

 

I did not save the new flow. I went into the old flow and voila, it was working again. I resubmitted all the failed runs and I'm back and running again. Txs anyway.

View solution in original post

2 REPLIES 2
ricardoj
Regular Visitor

So it is now working again (one detail I noticed was that it was now saying "Bad Gateway" in the Flow Excel Online connector.

 

Here is what I did, but I don't know if it was just a temporal thing and it fixed itself, or if what I did helped:

 

I created a new Flow with all the same elements (Mailbox access, OneDrive for Business, and Excel Online). There was a template that use all the 3. I use this template to create a new flow and it asked me again for permissions.  I was now able in this new flow to access the tables in my Excel file.

 

I did not save the new flow. I went into the old flow and voila, it was working again. I resubmitted all the failed runs and I'm back and running again. Txs anyway.

View solution in original post

@ricardoj  Could you please try to create a new Excel online connector in the Data-Connections and edit the flow using the newly created connector in the action?

 

 

Please mark my reply as a solution if you think it helps.

Thank you.

 

Best Regards,

 

Jessie Chen

 

Support Engineer

Screenshot_1.jpg

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MSFTBizAppsLaunchEvent

Experience what’s next for Power Virtual Agents

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Users online (58,975)