cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Resolver I
Resolver I

Flow unable to access OneDrive for Business - users are unauthorized

Hello everybody, I have created a flow to create a PDF document in OneDrive for Business. Everything works fine for me with my Office 365 Account but when my colleagues trigger this flow they get the following error:

 

Unauthorized. Action: Get Item (OneDrive)

Body:  "status": 401, "message": "Token contains invalid signature.", "source": "api.connectorp.svc.ms" 

 

I have given them full access in OneDrive but the error still occurs. Can anybody tell me what I'm doing wrong?

Thanks in advance.

4 REPLIES 4
Highlighted
Community Support
Community Support

Re: Flow unable to access OneDrive for Business - users are unauthorized

Hi @PowerAnalytics

 

Could you please share a screenshot of the configuration of your flow?

Have you add your colleagues as the owner your flow?

Please share more details so we would try to provide a proper workaround for you.

 

Best regards,

Alice

Highlighted
Resolver I
Resolver I

Re: Flow unable to access OneDrive for Business - users are unauthorized

Hi,

 

I have added my colleagues as the owner of my flow and the unauthorized message has disappeared.

 

Unfortunately now I get an error with statuscode 400: Bad Request and this message

"The provided item ID is not valid for the requested drive". Please find attached the screenshots of my flow.

Error MessageError MessageMy FlowMy Flow

Thank you so much!

 

Best regards,

 

Stef

Highlighted
Community Support
Community Support

Re: Flow unable to access OneDrive for Business - users are unauthorized

Hi @PowerAnalytics,

 

Could you please share the screenshot of your flow in English or could you please explain the actions?

In which action you have added a item id?

 

 

Best regards,

Alice

Highlighted
Resolver I
Resolver I

Re: Flow unable to access OneDrive for Business - users are unauthorized

Hi, it was the OneDrive for Business 'Get file content' action. In this action there was only a path to an image without a specific item ID.

 

Meanwhile, I have replaced the OneDrive 'Get file content' action with an SharePoint 'Get file content' action and now it works. But in my opinion it would be very useful for the community to resolve this issue.

 

Best regards.

 

Stef

Helpful resources

Announcements
firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Users online (10,230)