cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper I
Helper I

For a Selected Item Trigger not showing Document Libraries

Very much what the title says. I am an intern building a flow for document approval. I am trying to use the "for the selected item" trigger. I am able to enter the site, but it says List: No Items. We need these to work on SharePoint document libraries. How can I make "for the selected item" work for them?

 

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support
Community Support

Hi @atltt,

 

You could configure your Flow in this way.

Click on Templates, type "For a selected file" in the search box, and create a Flow using a template named "Complete a custom action for the selected file".

1.PNG

So you could choose a library that already exists in the site, shown as below:

2.PNG

Then you could configure other actions below, it is recommended to rename the Flow to find the corresponding Flow in the SharePoint library.

Please take a try.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

10 REPLIES 10
Super User III
Super User III

@atltt:

Are you saying that you can access a document library but you don't see any documents?  

If so, then either there are no documents in the library or those documents have not been shared with you.  Try creating a document to verify your permissions.

 

To run a "for a selected item" flow, you need at least contribute access to the library.  To use a selected item Flow, first select a document.  When you do so, you should see the Flow available to you under Flow on the library tool bar.

 

Also, remember that you'll need to share you Flow with your users on a run-only basis or they won't see the Flow.

 

If this does not address your issue, please provide additional explanation.

 

If this does address your issue, please mark your post as Solved.

 

Scott

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

Hey Scott, 

 

The issue is that the document libraries do not appear at all when I am trying to select them. I am a site collection admin, so proper rights should not be the issue.  Attached is the issue I am running into. We have over 20 document libraries, none of them are showing up.Capture.PNG

@atltt:

When using the For a Selected Item trigger with a library, you need to select "Enter custom value" from the drop down list and manually enter the library name.

 

Please give it a try and let me know if this works for you.

 

If this addresses your issue, please mark your post as solved.

 

Scott

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

Hey Scott, 

 

I just tried the custom input on two separate lists and that did not work. Any other ideas?

@atltt

 

Please post a screen shot of your Flow so that I can better assist.

 

Scott

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

@ScottShearer 

 

Here it is: tempsnip.png

 

 

I just blacked out some information like company name and my last name. "Management Processes" is a document library that I inputted with a custom variable.  I go to that document library and select a file and my Flow "Testing 1 2" does not show up. 

 

Thanks!

Community Support
Community Support

Hi @atltt,

 

You could configure your Flow in this way.

Click on Templates, type "For a selected file" in the search box, and create a Flow using a template named "Complete a custom action for the selected file".

1.PNG

So you could choose a library that already exists in the site, shown as below:

2.PNG

Then you could configure other actions below, it is recommended to rename the Flow to find the corresponding Flow in the SharePoint library.

Please take a try.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

@v-bacao-msft Will there be a point in the future where I won't have to use this workaround?

Hi

 

Having the same issue, did anyone manage to find out WHY, to resolve permanently.

 

Thx

Linda

@lallison 

Try this...

When creating your Flow, don't use the wizard that first appears - click on skip.  That takes you to a search screen where you can search for triggers or actions.  Enter "For a Selected" in the search box.  You'll see that For a Selected file does appear.  If you select SharePoint and look at the available triggers, it won't appear - looks like a bug to me.

SelectedFile.jpg

 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (2,181)