cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Playman2006
Frequent Visitor

Graph API Create User errors

Please HELP!

 

I have been working through many issues for a few weeks now. To help explain I am building a Power App that will create users within our Azure AD or O365 utilizing Graph API. I know that you can create users with Graph API, i have even had this work (at random and a one off, haven't gotten it to work since. Even when i tested it immediatly after) But no matter how many things i try PA is not giving me clear errors to work with. Has ANYONE ever created a user using the graph.microsoft.com/v1.0/users POST . It should be easy... 

 

Info: I am pulling string variables from Powerapps. A couple of objects i have pulled from a JSON object all the needed address data, language, and country data i need to also place in the user object. I know if you look up this post it does not show all data, but the user object accepts all of it. 

 

Can anyone help? 

1 ACCEPTED SOLUTION

Accepted Solutions

I was actually able to get it to work. I wanted to try and keep the connectors to a minumum so i don't have to make sure every user has access to those connectors. 

 

I found that the cryptic errors i was getting about validity came from the fact my On-prem account creation was synced up to the cloud and it could not create the new user. It was doing an "update" not a "new" when running the post /users for the graph API. 

Once i kept track of those details the Graph call is working perfectly. 

View solution in original post

2 REPLIES 2
PiebePost1
Helper I
Helper I

Had similar issues but am using the HTTP with Azure AD connector now, seems to eliminate all those buggy experiences. Are you using that connector too?

I was actually able to get it to work. I wanted to try and keep the connectors to a minumum so i don't have to make sure every user has access to those connectors. 

 

I found that the cryptic errors i was getting about validity came from the fact my On-prem account creation was synced up to the cloud and it could not create the new user. It was doing an "update" not a "new" when running the post /users for the graph API. 

Once i kept track of those details the Graph call is working perfectly. 

View solution in original post

Helpful resources

Announcements
2022 Release Wave 1 760x460.png

2022 Release Wave 1 Plan

Power Platform release plan for the 2022 release wave 1 describes all new features releasing from April 2022 through September 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Kudoed Authors
Users online (2,996)