cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
rys
Advocate II
Advocate II

Having Problems with Single Quotes or Apostrophes inside Flow to Sharepoint List

Hey All,

 

So I have a bunch of flows running that transfer people from one sharepoint list to another. I'm using an ODATA query to figure out if the user exists on the list already. 

 

First_x0020_Name eq 'DYNAMIC CONTENT FIRST NAME' and Last_x0020_Name eq 'DYNAMIC CONTENT LAST NAME'

 

So far I'm having great success except for one thing. For last names such as O'Brien and O'Reilly it's having issues with the apostrophe in the name. Anyone have any brilliant ideas on how I can make this work?

 

Thanks!

4 REPLIES 4
v-yuazh-msft
Community Support
Community Support

Hi @rys,

 

I have made a test on my side and the issue is confirmed on my side.

 

Please take a try to create the flow with a "Filter array" action as below:

Capture.PNG

 

When an item is created with the First Name is equal to O'Brien, the Last Name is equal to O'Reilly,

The flow would run successfully as below:

Capture.PNG

 

Best regards,

Alice

Hey Alice,

 

Thank you for this, however, I don't know how to make this work with what I'm doing. (sorry, newbie!)

 

I have the flow running on a recurrence, once per hour.

Flow

The ODATA query is in Get items 2 to see if the user exists, and then I use the following true/false condition to decide what to do with them:

@equals(length(body('Get_items_2')?['value']), 0)

 

I tried to drop in the filter array between the Get items 2 and the condition and then play with the condition statement, but I couldn't get it to work.

This works. Thanks a lot.

The issue is real in the built-in filter of "Get items", but it does not occur when using the array filter. For beginners, it is also possible to use the array filter with dynamic content, not only in the "advanced mode". This will then require a chain of multiple array filters, but it does not necessarily have to look pretty to work.

Best regards,

Eric

 

Ianbudson
Frequent Visitor

I know this is an old thread, but I had this issue and I found it easier to do this

How to use string with apostrophe (') in Power Automate filter query (tomriha.com)

 

Hope it helps.....

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (2,010)