cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Iro_
Helper I
Helper I

Http with Azure AD Connector giving encrypted response

Hello all,

 

I'm using http with Azure ID connector (with Data Gateway on-premises) to consume an Odata web service. When I call it from postman, I get a response like this:

 

Iro__3-1633599691103.png

 

When I call it from http connector the response is encrypted. Response status is 200, but I can not parse this response:

 

Iro__1-1633599493933.png

 

Iro__2-1633599597176.png

Any help would be greatly appreciated!

1 ACCEPTED SOLUTION

Accepted Solutions
eric-cheng
Solution Sage
Solution Sage

Hi @Iro_ ,

 

Can you try passing content in the body to the below and replace the part in bold.

 

@base64ToString(base64(xxxxx))

 

Please refer to my post in this thread for further details.

 

--------------------------------------------------------------------------
If I have answered your question, please mark my post as a solution
If you have found my response helpful, please give it a thumbs up

Connect on LinkedIn

View solution in original post

1 REPLY 1
eric-cheng
Solution Sage
Solution Sage

Hi @Iro_ ,

 

Can you try passing content in the body to the below and replace the part in bold.

 

@base64ToString(base64(xxxxx))

 

Please refer to my post in this thread for further details.

 

--------------------------------------------------------------------------
If I have answered your question, please mark my post as a solution
If you have found my response helpful, please give it a thumbs up

Connect on LinkedIn

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Kudoed Authors
Users online (1,009)