cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper II
Helper II

Re: Item Id doesn't belong to the current mailbox

@rhalabicki, are you having to initiate the connection in another action with a PUT or is this GET everything? 

Highlighted
Frequent Visitor

Re: Simple solution that helped for me

You have to create conection using my instruction. Because I also could not add sharedmail box using connection editor on the right. You have to you use those 3 dots (take a look at my screenshot).  First fix conection then everything should work. If something we can make teamviewer sesion 😉 Because I understand how frustrating it is... 

Highlighted
Helper II
Helper II

Re: Simple solution that helped for me

I got your method first try. 😁

Highlighted
Helper III
Helper III

Re: Item Id doesn't belong to the current mailbox

Hello Everyone,

 

Looks like the solution for Get-Attachment is to use "Invoke http request" which is an premium License requirement. My company doesn't have that license. Is there any way to get this working? 

I have used "get-attachment V2" and still same error as everyone is getting. As per the below documentation this "Action should work". Not sure why it is not working yet. 

 

This is frustrating and we need to stop our production roll-out because of this issue. Meanwhile I will also open ticket with Microsoft. 

My ORG also starting looking for third party solution instead of PowerAutomate as the changes are not consistent. 

Highlighted
Helper II
Helper II

Re: Item Id doesn't belong to the current mailbox

Do you or does someone have access to the admin center of M365? You can change the password for the shared mailbox’s user and then add a new connection to Flow. It will fix it.
Highlighted
Helper III
Helper III

Re: Item Id doesn't belong to the current mailbox

@jonathanford , are you saying to change the password of Shared Mailbox account itself or the user account that has permissions to the shared mailbox should be changed with new password? I believe we need to set Shared Mailbox password itself right? 

Highlighted
Helper II
Helper II

Re: Item Id doesn't belong to the current mailbox

The Shared Mailbox. There’s a guide further up in this thread to fix the issue. The premium license method is also not nearly as intuitive.
Highlighted
Helper II
Helper II

Re: Item Id doesn't belong to the current mailbox

Hi @kumarraj88,

Redirect all your incoming emails from shared mailbox (set a rule in Outlook) to your personal mailbox and then change mailbox address in Flow Trigger "When a new email arrived".


I explained all the steps above. If you need other explanations, don't hesitate to contact me.

For me - it worked and it seems much easier than other solutions.

Highlighted
Post Prodigy
Post Prodigy

Re: Item Id doesn't belong to the current mailbox

Hi @jeneaMD 

bad solution. Create a rule just to fix a bug?

 

If I were a MS boss, I'd return the "Invoke an HTTP request" action back to non-premium. 

Highlighted
Helper II
Helper II

Re: Item Id doesn't belong to the current mailbox

What is your solution @VictorIvanidze? 🙂

 

 

Highlighted
Post Prodigy
Post Prodigy

Re: Item Id doesn't belong to the current mailbox

Hi @jeneaMD,

 

unfortunately I haven't got my own solution

I've just followed the recommendations of @Mindaugas  and it helped me.

Highlighted
Helper III
Helper III

Re: Item Id doesn't belong to the current mailbox

@jeneaMD , Thanks for your suggestion. This solution can be a temporary purpose. Because daily we (shared mailbox) receive more than 600 reports/attachments. I don't want my mailbox to flood with these emails and different to load them due to high quantity. 

 

I am trying password reset today and if that doesn't work then I will set the rule as per your suggestion until Microsoft fix this.  We will be also opening ticket with Microsoft and I will keep posted on this.  This is frustrating for sure. 

Highlighted
Frequent Visitor

Re: Item Id doesn't belong to the current mailbox

@jeneaMD  is your solution sustainable?  What happens when you get hit by the lottery bus, leave the company and the delete your account?  All your flows stop working?  I know it wouldn't be your issue, but usually we don't want to screw over then next guy.

Highlighted
Helper II
Helper II

Re: Item Id doesn't belong to the current mailbox

@sobenson, thank you for being ironic, but as @kumarraj88 said earlier: when you have hundreds of emails/attachments that should be saved somewhere in the cloud on a daily basis and you don't have other solution until Microsoft will solve it or will propose alternatives --> then, yes, is sustainable.
Other solutions proposed are not applicable for me.

And yes, in my organization, each employee has a back-up, don't worry about my financial health. 🙂

 

Highlighted
Advocate III
Advocate III

Re: Item Id doesn't belong to the current mailbox

Looks like if you have the trigger "When a new email arrives in a shared mailbox" attachment content is in there and appears to work without issue, for those who are trying to get attachments from a shared mailbox, might have to "enable" via the advanced options in the trigger

Highlighted
Regular Visitor

Re: Item Id doesn't belong to the current mailbox

This is so shocking! So many Production flows use shared mailboxes... beginning of the end of the Microsoft platform?

Highlighted
Frequent Visitor

Re: Item Id doesn't belong to the current mailbox

Agree with @srduval , the "When a new email arrives in a shared mailbox" trigger is still working.  The issue was sending a command to do something to the message after that.  Using the SharePoint action "Create file" to a SharePoint site is still working. 

 

We were all exploiting a bug that was patched.  MS has done their jobs and fix a flaw.  Would it be great if they released Shared Mailbox actions, yes.  I am sure there are User Voice posts asking for this.  

Highlighted
Advocate I
Advocate I

Re: Item Id doesn't belong to the current mailbox

I am having the same issue. Following

Highlighted
Advocate II
Advocate II

Re: Simple solution that helped for me

@Mindaugas Thank you for sharing!! This worked for me also. 

 

Anybody still facing this problem should definitely try the solution posted by Mindaugas.

 

Be advised that if you do not sign-in to Shared Mailboxes typically (I do not either), then you will need to set a password manually in Office Admin center. 

 

-RHCC

 

Per Mindaugas:

Hey Guys got this problem from Wednesday too. I have a flow witch reads mail in sharedmailbox, saves attachmetns to sharepoint and marks email as read.

 

1. First you have to know password of sharedmailbox IF Not go admin center -> active user -> find shared mailbox and get password.

 

2. Go to your MS flow that keeps failing. Then Edit.

 

3. Find action that is failing in my case it was "Mark as read or unread V2"

 

4. Then push 3 dots. And there is +Add new connection select it.

 

 

5. Enter sharedmailbox adress and password.

 

6. Checked if it appeared among other conections. As in step 4 if not try again. ( Few times needed for me.)

 

Wordked for me.

Highlighted
Advocate I
Advocate I

Re: Simple solution that helped for me

any suggestions for those of us that do not have access to the admin center? (it's blocked)

 

Thanks!

Helpful resources

Announcements
firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (5,792)