cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

Microsoft Flow - SharePoint Connection - Unauthorized?

I have recently built a flow the gets all MS Form responses and puts it into a SharePoint List.

After heaps of testing and countless successful flows it all of a sudden decides to make the connection to SharePoint "Unauthorized".

Forms Flow Unauthorized.jpg

 

The funny this is it is only intermittent. Most of the time failing but some times running fine.

 

I have tried the following;

  • Deleting and creating a new connection.
  • Copying the flows.

I did recently change some the view setting in the list but I'm sure this would not explain this failure. 

Oh and I am the owner of the SharePoint site.

I'm a little lost without any information regarding the failure.

 

Any Ideas?

24 REPLIES 24
Highlighted

I am now getting the token error as well.
Community Support
Community Support

Hi All,

 

MS Flow Support has released an update and this issue seems to have been resolved.

https://preview.flow.microsoft.com/en-us/support/

Please check if there is still an issue with the related Flow. If so, please let us know.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted

Thank Barry,

 

It appears that the issue has been fixed on my end.

 

Just as a side note it would be nice to find out what the issue actually was.

Highlighted

The issues of last week were well followed by MS admins in this thread:

 

https://powerusers.microsoft.com/t5/General-Discussion/Apps-wont-load-I-cant-even-get-a-list-of-them...

 

The Flow issue appeared to be:

 

 
Mr-Dang-MSFT
Administrator 
Administrator
Re: Apps wont load! I cant even get a list of them.

@martinav 

The SharePoint connector issue in Flow that was throwing throttling errors has been resolved.

View solution in original post

Highlighted
New Member

This issue seems to have recurred. We have over a dozen previously working flows that are randomly showing connection unauthorized errors. I've tested multiple levels of permissions for SharePoint list and site collection access, multiple accounts, new connections, and recreating a flow from scratch. Nothing helps. All of the errors are on the trigger action. Some flows referencing the same connection, the same site collection, and the same list, trigger and work correctly. All of the flows are shared with the same owners and reference the same group of sites collections and lists. Trigger actions are added, updated, and deleted.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Users online (8,739)