cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Mutiple Microsoft Accounts now broken for Outlook connector

In the past I could add multiple connections to different personal Microsoft Accounts to manage my email workflows via a single Flow. Now there is a bug whenever you try to add a new connection for Outlook using a MSA the browser opens a sign-in window but then immediately signs in using your current MSA - not expected or wanted. Previously I could add a separate MSAs, so I could manage email workflows across multiple Microsoft personal Outlook accounts. Now it just creates multiple connections of the same MSA Outlook email due to the automatic sign in issue. Is this expected change in the workflow or should I be able to add multiple Outlook connections (like was possible previously)?

 

Update: Found a solution that if you click fast, during in the 2sec you have before it signs you in with the wrong (existing) account, on 'create new account' it interrupts the sign in. Then go back you have just long enough time to type in the MSA email you actually want to use. Very questionable design. 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User II
Super User II

Re: Mutiple Microsoft Accounts now broken for Outlook connector

Hi @DominicX ,

 

Super strange, but I think this is a bug. 

 

You have the issue and the reproducible steps so I would recommend submitting a ticket to the Flow's support:

https://admin.powerplatform.microsoft.com/support?newTicket&product=Flow

 

This will allow the team to take a look and try to fix it. 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Cheers
Manuel

View solution in original post

2 REPLIES 2
Highlighted
Super User II
Super User II

Re: Mutiple Microsoft Accounts now broken for Outlook connector

Hi @DominicX ,

 

Super strange, but I think this is a bug. 

 

You have the issue and the reproducible steps so I would recommend submitting a ticket to the Flow's support:

https://admin.powerplatform.microsoft.com/support?newTicket&product=Flow

 

This will allow the team to take a look and try to fix it. 

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Cheers
Manuel

View solution in original post

Highlighted
New Member

Re: Mutiple Microsoft Accounts now broken for Outlook connector

You cannot follow that link with an MSA however the Flow is using an MSA. Do you have a ticket request link for MSA users?

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (7,682)