cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AK42
Frequent Visitor

New SQL connection not available in Get rows (V2) action

I use an on-prem SQL server. I have registered a gateway and then created a new connection to use the gateway with SQL authentication. But when creating a flow, if I add a "Get rows (V2)" action, under server name drop down, the new connection cannot be selected. If I create a new flow from a template and create a SQL connection that way (which gives you Windows authentication or basic authentication so I picked basic), then the connection can be selected in Get rows (V2). Is this a normal behavior? How come there are different authentication options between the 2 ways to create a SQL connection? What is the proper way to do this?

Apologize for a basic question.

Thank you very much in advance. 

3 REPLIES 3
v-alzhan-msft
Community Support
Community Support

Hi @AK42, Could you please share more details about the issue? This isn't a normal behavior. Have you choose the same connection for the server when you add "Get rows (V2)" directly and create a new flow from template? Best regards, Alice Community Support Team _ Alice Zhang If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I have registered the data gateway for the on-prem SQL server in my O365 account so it was showing up under Data > Gateways.

I then started creating a new flow (scheduled - from blank). I added a "Get rows (V2)" step but the server name drop down didn't show my new gateway. I realized that I need to configure a new SQL connection so I went to Data > Connections > New connection and selected "SQL Server". It provides 3 authentication types (Azure, SQL, Windows) so I selected SQL and entered the SQL login name and password. The new connection was added to the list and it said "Connected". I went back to "Get rows (V2)" but the server name drop down didn't show the new connection so I couldn't create a new flow to use the SQL server. 

I then went to New > "Create from template" and selected the template "Notify about rows in a SQL DB". The template says "This flow will connect to" and lists connectors. I clicked "Create" next to SQL server, checked "Connect via on-premises data gateway" and added all the information. Unlike the case when creating a new SQL connection from scratch, this method within a template provides Windows or Basic authentication types only. I selected basic and created the connection. I cancelled the creation of the flow since the connection was already created and saved. At this point, I was able to select the connection from "Get rows (V2)" step and proceed with the creation of the flow.

AK42
Frequent Visitor

I don't know how the status changed to "solved" but I'm still looking for an answer. Can I reverse the "solved" status?

Helpful resources

Announcements
MPA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.

Users online (1,108)