cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

O365 webhook works from installed app but not chrome

Hey there,

I have built a process within cherwell that leverages the O365 connector to send over a message card to teams, which triggers a Flow.  This all works fine from the installed app, but when Cherwell client is opened in the web browser and the same process is run, we are presented with an error:

ReceiveFailure: The underlying connection was closed: An unexpected error occured on receive.

 

As stated, this works perfectly in the Cherwell installed client app, so I am guessing it is due to the request coming from the web (Chrome) and not the app.

 

Not sure what to do to fix this.  Most of the users are using Cherwell in Chrome as they are running Linux.

 

Thank you.

2 REPLIES 2
Highlighted
Community Support
Community Support

Re: O365 webhook works from installed app but not chrome

Hi @stevenls,

 

It's unfortunate that Flow doesn't support connection with Cherwell Service Management yet.

There is a similar idea has submitted in IDEA forum, you could head to vote it to make it come true in the future:

https://powerusers.microsoft.com/t5/Power-Automate-Ideas/Cherwell-Service-Management-support/idi-p/2...

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Highlighted
Advocate I
Advocate I

Re: O365 webhook works from installed app but not chrome

Hey there,

Thanks for the reply but I wasn't asking about a feature to be added.

I already have this working..  A process is triggered in Cherwell, bundles up the ticket information as JSON and sends it over to Teams via the O365 webhook as a MessageCard.  Flow then detects the message, strips out the JSON and then makes a mention to the technician with all the ticket information.

 

All this is working from the Cherwell installed client app.  It comes up with the error from the original post when the same process is tried to be run from the Cherwell client opened in Chrome.

 

That error is my issue and not sure what to do about Chrome actioning all of that differently than the installed app.

 

Thanks

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Tech Marathon

Maratón de Soluciones de Negocio Microsoft

Una semana de contenido con +100 sesiones educativas, consultorios, +10 workshops Premium, Hackaton, EXPO, Networking Hall y mucho más!

Top Solution Authors
Top Kudoed Authors
Users online (7,243)