cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
bnixon
Regular Visitor

OneNote (business) connector - Unable to parse site ids from OneNote API

I am using Flow in a Office 365 Government G3 tentant and having problems using the OneNote (business) connector to Get sections in notebook, which returns with BadGateway, Status Code 502, and Body below:

{
  "error": {
    "code": 502,
    "message": "Unable to parse site ids from OneNote API. Code: 500, Response:",
    "source": "flow-apim-msmanaged-na-westus2-01.azure-apim.net",
    "path": "choose[4]\\when[1]\\choose[2]\\when[1]",
    "clientRequestId": "3ce57d0e-e10e-413a-9d1d-c6be0e784f0b"
  }
}

I tried to debug using a new flow, with just Get pages for specific section. The dropbox for Notebook Key populates with all my Notebooks, however when I select any Notebook, the dropbox for Notebook section shows "Could not retrieve values. Unable to parse site ids from OneNote API. Code: 500, Response:"

29 REPLIES 29
Anonymous
Not applicable

@Yeiner  can we get an update regarding a fix ETA for this tool?

Yeiner
Community Support
Community Support

Hello @Anonymous are you asking for GCC? 

Yeiner
Community Support
Community Support

Hello @Anonymous  based on my research, this is now available for GCC. did you try?

bnixon
Regular Visitor

@Yeiner This is still not working, for me at least. Try and reproduce by creating a new flow, add "Get pages for a specific section", select a Notebook Key, and then try and select a Notebook section. You should see something like this Flow Error.

 

In my opinion, this is embarrassing for Microsoft. I've escalated this issue with my Microsoft reps, and thru this forum, with no success. And, what I see in this forum is people related to MS saying it's working, without any real "research" into the issue, and users like me restating the issue and pointing out potential causes, like a permission issue.

 

Is there a more formal way to file a bug report?

 

 

I am also still getting this error in GCC.

 

I actually did file a ticket for this back in September and worked with @Yeiner.  It was closed because the team knew about the issue and was actively working on a fix.

Yeiner
Community Support
Community Support

Hello All,

 

First of all, I want to apologize for the delay in my response.

 

We are having an issue with the API and we are currently working on this.

 

I will keep you posted 

It appears that this is working now.  Can anyone else confirm?

Yeiner
Community Support
Community Support

Hello @Yocomd I did a test and its working now 🙂

bnixon
Regular Visitor

I confirmed it is working for me as well. US G3 Cloud

Hi @Yeiner ,

Was it ever fixed?  2 years later!

I work in an Educationnal A3 environnement and I've having the same problem.

 

Thanks

--mo

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Kudoed Authors
Users online (1,835)