cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Regular Visitor

Outlook trigger "When a new email arrives" not detecting new mail

I started out making a flow using the when a new email arrives in a shared mailbox, but that's still in preview mode I guess. I was having the same issue with that connector.

Anyhow the only time I can get the flow to fire is when I test the flow using the "test flow" button and send an email to the box. If the flow is not in test mode, it never fires--I don't even get an error message. Do I need to open a ticket with microsoft, is the outlook connector buggy? Is there something I'm missing?

 

wtf.png



9 REPLIES 9
Highlighted
Community Support
Community Support

Hi @ gdhi11,

 

I have made a test on my side, and don't have the issue that you mentioned.

The trigger  "When a new email arrives" and "when a new email arrives in a shared mailbox" all work well to trigger the flow when a new email arrives or a new email arrives in a shared mailbox.

 

Please check if you have click the "Create flow" when you have finished to create the flow,and check if the email is with the same "Foder","To","Importance","Has Attachment", etc, as the configuation in your trigger.

 

Please wait for some minutes before the flow runs when the email arrives,sometimes the trigger would response some minutes later than when the email arrives.

 

In addition, please refresh the flow when the email arrives, and click the flow to see the run history of the flow, and check if the flow has run.

Capture.PNG

 

Please let me know if your problem could be solved.

 

 

 

Regards,
Alice Zhang

Highlighted

The Run history has 2 runs in it, but I've sent 20-30 emails into the box, so it's literally not running when it receives mail. I have also recreated the configuration from scratch with the same effect.

Highlighted

Hi @ gdhi11,

 

Could you please share a full screenshot of the configuration of your flow?

Could you please share more details about the configuation of the trigger "When a new email arrives"?

 

Please share more details so we could provide a proper workaround for you.

 

Regards,
Alice Zhang

Highlighted

For Flow Forum.png

Highlighted

The one successful run was from when I was in test mode. It is still active and not looking at any inbound emails to dhill@*******

Highlighted

I have the same problem. Is there a doc that describes how can I set a flow triggered by "When a new email arrives in a shared mailbox"? How can I debug? Which connections should I use?

 

Thanks. 

Highlighted

Hi @gdhi11

I dont have the problem you mentioned, but just a thought.. in your printscreens I see you have When a new email arrives, but you mentioned you want it for a shared mailbox, did you try with When a new email arrives in a shared mailbox?

 

Edit: sry, now I see that the post is from last year 🙂

 

@VictorIvanidze maybe it has something to do with your rights on that shared mailbox? check your permission level.

 





Did I answer your question? Mark my post as a solution!

Proud to be a Flownaut!





Highlighted

@Dorul,

it seems i fixed it myself. I've exported the flow and then imported it back and reset the connections.

Now it works as it should.

Thanks.

Highlighted
Anonymous
Not applicable

I have the exact same issue. It works for sometime and then completely stops and then starts all by itself. Definitely a buggy connector.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Users online (12,153)