cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
TlvRoadRunner
Frequent Visitor

SQL execute stored procedure V2

Hi

 

I'm trying to execute a stored procedure with an SQL Server connecter via on-prem gateway and I get the below error.

I have older flows that use 'execute stored procedure (v1)' on the same gateway and are running daily without any issue.

I've tried to remove and recreate the connector and that did not help.

Thanks

SP_GW.png

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

For anyone reaching this post. If you need to reference the port in the database address, you must do it with ":".

Address convention should be <server_address>:<port> and NOT <server_address>,<port>.

 

This solves the issue.

 

Cheers

View solution in original post

6 REPLIES 6
v-alzhan-msft
Community Support
Community Support

Hi @TlvRoadRunner ;

 

Could you choose the server from the drop-down list in the Execute stored procedure?

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Alice,

 

Yes - for the 'Database Name' and 'Server Name' I'm abale to select the value from the dropdown menu, i.e. without typing it in.

The error occurs when I try to do the same for the 'Procedure Name' field.

 

Thanks!

For anyone reaching this post. If you need to reference the port in the database address, you must do it with ":".

Address convention should be <server_address>:<port> and NOT <server_address>,<port>.

 

This solves the issue.

 

Cheers

View solution in original post

Hi @TlvRoadRunner,

 

I am having this issue too but am unsure what your solution means, could you please share a screenshot of your configuration please so I can see what I have to do to rectify?

Hey

 

If you need to reference the port in the connection string it should be using    ":"

 

For example:

db_address:403    whereas 403 is the port

Hi ,

I am facing an issue in the power automate flow in a step of 'Execute_stored_procedure_(V2)'.

Please find the error message below.   Invalid connection settings inner exception: Not a valid data source. clientRequestId: c338b978-c6fb-42b1-85f1-57a199f946f6   { "status" : 400 , "message" : "Invalid connection settings\r\n inner exception: Not a valid data source.\r\nclientRequestId: c338b978-c6fb-42b1-85f1-57a199f946f6" , "error" : { "message" : "Invalid connection settings\r\n inner exception: Not a valid data source." }, "source" : "sql-we.azconn-we.p.azurewebsites.net" }

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (46,679)