cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jchammons
Regular Visitor

Send an email (V2) will not allow Dynamic Content

I have an approval process for a Microsoft form:

  1. Form submitted
  2. Get form response details
  3. Get user profile V2
  4. Get manager V2
  5. Create item in Sharepoint list
  6. Start and Wait for Approval
  7. Condition outcome equal Approve
  8. Yes or No send email Apply to each loop is after approval
  9. Yes send email V2.  The "to" field is not allowing dynamic content to select the "user Mail" email to send them the outcome of the approval
  10. No send email V2 is allowing dynamic content and I can select the "Mail" for the user and manager

Why can I not use dynamic email here? 

1 ACCEPTED SOLUTION

Accepted Solutions

Yep I turned off the experimental settings and was able to access the fields that I wanted better.  For some reason, the "mail" user still didn't want to show up.  Later the "mail" user dynamic field started working.   So far the flow seems to be working finally.  Thanks for the help

View solution in original post

8 REPLIES 8
Pstork1
Dual Super User III
Dual Super User III

What dynamic content are you using to set the email?  I just tried to reproduce your issue using an email address entered in response to a question on the form and it works fine for me both inside and outside the loop.

image.png

 



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

For some reason, it allows me to add "Mail" for the user profile now but gives me an error now.   Sometimes the "to" field will not allow me to dynamically select "mail".  

jchammons_0-1621949880822.png

 

Here is the error message.  The field is not empty. 

 

jchammons_1-1621950138753.png

 

 

 

Pstork1
Dual Super User III
Dual Super User III

The Mail dynamic content you are adding represents the email address of the user's manager in Azure Active Directory.  User's are not guaranteed to have a manger in their profile and those managers may or may not have an email.  The error is saying the manager's email is empty either because there was no manager or there was no email.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

That is the odd thing.  I have a different approval process for leave approval.  The Active Directory information works correctly for that flow.  

I tried recreating the flow from scratch.  Now I am getting the original problem.  I cannot select any Dynamic fields for the email.  

Pstork1
Dual Super User III
Dual Super User III

MS is in the process of changing the editor experience on this.  Are you seeing a separate dialog with dynamic fields or two buttons to choose a dynamic content list/expressions editor?  I'm now seeing the newer expressions editor and have had to click several times on the dynamics content list to get it to show occasionally.

image.png

If you aren't seeing the newer experience and aren't seeing dynamic content, make sure you click on the double arrows to switch between advanced and basic entry.  Dynamic content tends to only appear in one.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

When I click in the "to" section of the Send Email V2, I do see the blue dialog boxes.  I click on it and it flashes sort.  of.   Is there a way to work around this or stop this from happening?

jchammons_0-1621957791049.png

 

When I click in the "subject", then it will allow me to access dynamic content. 

Pstork1
Dual Super User III
Dual Super User III

That's what I meant when I said I had to click in and out of the box and on the blue button a couple times before the dynamic content list would stay and not just flash.  Its a newer experimental dialogue and I think there are still some display bugs.  Try turning off experimental settings in the Power Admin settings for the flow.  Or just keep clicking til it shows up.  It did for me after a couple tries.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Yep I turned off the experimental settings and was able to access the fields that I wanted better.  For some reason, the "mail" user still didn't want to show up.  Later the "mail" user dynamic field started working.   So far the flow seems to be working finally.  Thanks for the help

View solution in original post

Helpful resources

Announcements
MPA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

R2 (Green) 768 x 460px.png

Microsoft Dynamics 365 & Power Platform User Professionals

DynamicsCon is a FREE, 4 half-day virtual learning experience for 11,000+ Microsoft Business Application users and professionals.

Users online (1,240)