cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MarkStokes
Skilled Sharer
Skilled Sharer

Service Bus Connection String

Hi,

 

Can anyone help me form a connection string for a Service Bus connection in Flow?  If I enter the connection string that the Azure portal gives me: (obviously i have snipped my actual details here)

Endpoint=sb://<snip>.servicebus.windows.net/;SharedAccessKeyName=<snip>;SharedAccessKey=<snip snip>=;EntityPath=newsletter

  

Body
{ "status": 400, "message": "ConnectionString should not include EntityPath.", "source": "127.0.0.1" }
 
Fair enough.  I remove the Entity Path element:
Endpoint=sb://<snip>.servicebus.windows.net/;SharedAccessKeyName=<snip>;SharedAccessKey=<snip snip>=;
Body
{
  "status": 401,
  "message": "40103: Invalid authorization token signature, Resource:sb://<snip>.servicebus.windows.net/newsletter. TrackingId:bf7ec8af-c29b-417d-b1bd-846074dad7aa_G9, SystemTracker:<snip>.servicebus.windows.net:newsletter, Timestamp:7/1/2016 4:47:13 PM",
  "source": "127.0.0.1"
}
So, does anyone know how I should format my connection string?
 
Thanks
1 ACCEPTED SOLUTION

Accepted Solutions
SameerCh
Power Automate
Power Automate

Snipping off the Entity path will not work, unfortunately.  You can get the Connection string for the root namespace.  For this, just navigate to the screen which list the namespace, select the namespace and click on "Connection Information".

View solution in original post

3 REPLIES 3
SameerCh
Power Automate
Power Automate

Snipping off the Entity path will not work, unfortunately.  You can get the Connection string for the root namespace.  For this, just navigate to the screen which list the namespace, select the namespace and click on "Connection Information".

View solution in original post

Thanks, that sorted it.

 

It didn't occur to me that the Connection String at teh root of the namespace would be different to the one in the Queue page.

 

 

When i pull the connection string from teh root namepace I still get the error when I run the flow. Adding the connection works fine.

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Users online (21,496)