cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

SharePoint Document Library not pulling in data to flow.

I have a document collaboration Flow. It runs when someone moves the field from 'No' to 'Yes'. Then it should send an email and create a task. Here are the parameters and the error.

EmailEmailEmail errorEmail error

Task ErrorTask ErrorTaskTask

 

Any ideas?

3 REPLIES 3
Community Support
Community Support

Hi @Anonymous,

 

Do you want to send an email to the Reviewer when a field of the library is set to Yes, and then create a task in Outlook Tasks?

From the screenshot, it seems that the dynamic contents you selected returned null value. Please make sure you have given them a value in the library.

I have made the following test according to your description.

First, create a document library with the columns you mentioned. A Completed column of type choice Yes/No, one Reviewer column of type Person and group, one DueDate column of type Date and time (date only).

Then start the flow with the trigger When a file is created or modified (properties only).

Add a condition to check whether the Completed is equal to Yes with the following code in advanced mode:

@equals(triggerBody()?['Completed'], bool('true'))

 

Under if yes branch, send an email to Reviewer, create a task to Tasks.

A screenshot for your reference.

1.PNG2.PNG

Please take another try with it and feel free post back if you are still having the issue. 

 

Best regards,

Mabel

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

I put in the logic you suggested (thank you!), but then it wouldn't wait for me to move the field to 'Yes', so changed the logic to send the email even if it isn't going back to the trigger. 

 

flow2.PNG

Hi @Anonymous,

 

Could you share a full screenshot of your flow?

It seems that there is a Do-until loop in your flow. How is the do-until condition configured?

When using Do-until loop, the data is not pulled in from the previous step but instead it is part of the Do-until block itself.

Please share more details on your flow to help reproduce this issue.

 

Best regards,

Mabel

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (7,534)