cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mhoff
Level: Powered On

Sharepoint 400 error - new item created in list

Trying to have a flow create a post on Slack when an item is created in a Sharepoint list. I'm able to set up the flow and select the Sharepoint list. When the flow runs it throws an error through in the first step: "status": 400, "message": "The query to field 'Client/LinkTitleNoMenu' is not valid.",

 

Is this an issue with the list setup or with connecting to Sharepoint?

 

I get a similar error for catching updates to items in a list.

9 REPLIES 9
Microsoft telu
Microsoft

Re: Sharepoint 400 error - new item created in list

Hi mhoff,

 

I have created a similiar flow, it works for me, could you send me the flow url for me to further investigate?

like this: https://tip1.flow.microsoft.com/manage/flows/6ef61db7-3e0f-4098-b467-7eae474a4b0f

sharepoint-slack.png

Thanks,

telu

mhoff
Level: Powered On

Re: Sharepoint 400 error - new item created in list

I think the error is as a result of a field in Sharepoint, and not so much due to the Flow setup.

 

"The query to field 'Client/LinkTitleNoMenu' is not valid"

 

Client is a field on the list that is driven by a drop down menu. Need to figure out why the query isn't working.

Microsoft telu
Microsoft

Re: Sharepoint 400 error - new item created in list

Yes, maybe it doesn't contain list, you can give me the flow url for further investigation.

 

Thanks

mhoff
Level: Powered On

Re: Sharepoint 400 error - new item created in list

seanmchugh
Level: Powered On

Re: Sharepoint 400 error - new item created in list

I have the same issue ... definitely looks like an issue with linked fields ... is your field populated with data from other items in the list (or another list).  Mine is and it gets the same error.

 

 
mhoff
Level: Powered On

Re: Sharepoint 400 error - new item created in list

Yes the field is linked to another list in ours as well.

em_sc
Level: Powered On

Re: Sharepoint 400 error - new item created in list

Nobody ever responded or solved this? I have the same issue.

MarceloAP
Level: Power Up

Re: Sharepoint 400 error - new item created in list

Same problem  here. Any answers out there?

em_sc
Level: Powered On

Re: Sharepoint 400 error - new item created in list

I am not working on it anymore but I couldn't find anything.....

Helpful resources

Announcements
firstImage

Power Platform Online Conference

Join us for the first ever Power Platform Online Conference!

firstImage

Incoming: New and improved badges!

Look out for new contribution recognition badges coming SOON!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Users online (3,842)