cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

There's a problem with the flow's trigger.

Hi!

Could you help me? What I do wrong?

 

I have a flow that makes use of the "When a feed is published" flow trigger. The RSS feed address has a valid RSS feed .
The RSS feed URL:

https://cloudblog.withgoogle.com/rss/

 

The flow was failed on the first step with an error:

{
"status": 400,
"message": "Failed to read requested Feed information. Details: 'Element' is an invalid XmlNodeType. Line 2, position 25866.\r\nclientRequestId: 0edf33e9-74ef-4ae9-9b94-419814b69c71",
"error": {
"message": "Failed to read requested Feed information. Details: 'Element' is an invalid XmlNodeType. Line 2, position 25866."
},
"source": "rss-ne.azconn-ne.p.azurewebsites.net"
}

Headers:
{
"Pragma": "no-cache",
"x-ms-request-id": "0edf33e9-74ef-4ae9-9b94-419814b69c71",
"Strict-Transport-Security": "max-age=31536000; includeSubDomains",
"X-Content-Type-Options": "nosniff",
"X-Frame-Options": "DENY",
"Timing-Allow-Origin": "*",
"x-ms-apihub-cached-response": "true",
"Cache-Control": "no-store, no-cache",
"Date": "Mon, 17 Aug 2020 18:07:44 GMT",
"Set-Cookie": "ARRAffinity=de3b10a934af9f1a63b114c049a04afeade855bfd755f5c58629d86d56d64502;Path=/;HttpOnly;Domain=rss-ne.azconn-ne.p.azurewebsites.net",
"Content-Length": "412",
"Content-Type": "application/json",
"Expires": "-1"
}

3 REPLIES 3
Anonymous
Not applicable

9999.PNG

 

v-bacao-msft
Community Support
Community Support

 

Hi @Anonymous ,

 

I filled this URL in the List all RSS feed items action for a test and encountered the same error.

It seems that there are unexpected elements in the data returned by this URL. Please refer to this similar thread and see if it helps:

Unable to use RSS Feed as Trigger - Same Error on ... - Power Platform Community

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

I've seen it before, and it didn't help me.

 

Does anyone have any other ideas on how to fix this error?

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,552)