cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

Using HTTP POST with Twilio

Hello Everyone,

 

I am hoping to get some assistance on a POST I am trying to make to the Twilio REST Api. My scenario is as follows, we have a customer survey stored in Twilio as a Studio execution. These executions can be triggered by a POST to their rest API. I have tested it in Postman and got it working in Postman. 

 

My end goal is to use MS flow to handle the POST that way I can feed the execution a phone number based on other parameters from our organization. 

 

Has anyone worked with this before? Here is a capture of the HTTP data that Postman sends across as a request. 

 

 

POST /v1/Flows/FWXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX/Executions HTTP/1.1
Host: studio.twilio.com
Content-Type: multipart/form-data; boundary=----WebKitFormBoundary7MA4YWxkTrZu0gW
Authorization: Basic AccountSID:Auth Code
User-Agent: PostmanRuntime/7.19.0
Accept: */*
Cache-Control: no-cache
Postman-Token: XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX,XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX
Host: studio.twilio.com
Accept-Encoding: gzip, deflate
Content-Length: 284
Connection: keep-alive
cache-control: no-cache


Content-Disposition: form-data; name="To"

+15551112222
------WebKitFormBoundary7MA4YWxkTrZu0gW--,
Content-Disposition: form-data; name="To"

+15551112222
------WebKitFormBoundary7MA4YWxkTrZu0gW--
Content-Disposition: form-data; name="From"

+15552221111
------WebKitFormBoundary7MA4YWxkTrZu0gW--

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Advocate I
Advocate I

Re: Using HTTP POST with Twilio

Good news, @AKRogers @edgonzales , I got it working!!!!

 

The key is to understand how the form data boundaries work, basically the form data needs to include a boundary that is declared by the user in the header. In your body , you use the boundary to delimit all the form data parts. In the body, you'll need to add two extra hyphens as a prefix of the declared boundary, when you are done adding the last type of form data you close the POST with the boundary plus two suffix hyphens. (code snippet below).

 

The header must be

Content-Type multipart/form-data; boundary=----YOURBOUNDARYHERE

 

Body 

------YOURBOUNDARYHERE
Content-Disposition: form-data; name="To"

+PHONE NUMBER HERE
------YOURBOUNDARYHERE
Content-Disposition: form-data; name="From"

+PHONE NUMBER HERE
------YOURBOUNDARYHERE--

 

 

 

Once I got the syntax, it was actually super easy. This exponentially expands the capabilities of using Twilio with flow. Thanks for all your advice!

 

 

View solution in original post

16 REPLIES 16
Highlighted
Helper V
Helper V

Re: Using HTTP POST with Twilio

@edmm94,

 

Sounds like you might need a little more power than the out of the box actions that are available for Twilio in Power Automate (MS Flow).  Have you looked into using HTTP actions to POST to Twilio?  If you have, please screenshot what you're doing and we can talk a bit more about where you might be stuck.  If you haven't started, just know that the HTTP connector is premium.  

 

Ashley

If you found this helpful, consider giving it a thumbs up!

Highlighted
Super User II
Super User II

Re: Using HTTP POST with Twilio

@edmm94 

Hi there. So, the HTTP action should work for this (it's a Premium connector).  Have you already tried that?  Here's an article covering the action and how I used it to connect to Yelp.

 

-Ed-

 

If you liked this reply, please give it a thumbs up! If this reply has answered your question or resolved your challenge, please consider marking it as a Solution. This helps other users find it more easily via search.

Highlighted
Advocate I
Advocate I

Re: Using HTTP POST with Twilio

Hi Ashley,

 

Yes! I have been trying to use the HTTP Post connector. 

 

I have tried a number of things. I just thing I keep tripping myself up on syntax. I even tried posting from Postman to a MS Flow URL in order to see what request came across but that did not work the way I thought it would. 

 

Here a screenshot of the latest.

 

Post Headers.png

 

Body

{
  "$content-type": "multipart/form-data; boundary=--------------------------329424697522232853751243",
  "$content": "LS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLTMyOTQyNDY5NzUyMjIzMjg1Mzc1MTI0Mw0KQ29udGVudC1EaXNwb3NpdGlvbjogZm9ybS1kYXRhOyBuYW1lPSJUbyINCg0KKzE2MzA2MzI4ODUyDQotLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tMzI5NDI0Njk3NTIyMjMyODUzNzUxMjQzDQpDb250ZW50LURpc3Bvc2l0aW9uOiBmb3JtLWRhdGE7IG5hbWU9IkZyb20iDQoNCisxMjA1NDQyMDUzMg0KLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLS0tLTMyOTQyNDY5NzUyMjIzMjg1Mzc1MTI0My0tDQo=",
  "$multipart": [
    {
      "headers": {
        "Content-Disposition": "form-data; name=\"To\""
      },
      "body": {
        "$content-type": "application/octet-stream",
        "$content": "XXXXXXXXXXXXXXX"
      }
    },
    {
      "headers": {
        "Content-Disposition": "form-data; name=\"From\""
      },
      "body": {
        "$content-type": "application/octet-stream",
        "$content": "XXXXXXXXXXXXXXXX"
      }
    }
  ]
}

 

Response from Twilio

Response.png 

 

Highlighted
Advocate I
Advocate I

Re: Using HTTP POST with Twilio

Hi @edgonzales thanks! Yes, I have been trying with the HTTP action but this article is really clearing things up. I posted a reply to another comment on here with what I have tried.

 

 

Highlighted
Helper V
Helper V

Re: Using HTTP POST with Twilio

@edmm94, how's this going for you?  From your error message yesterday it looks like what you're sending to Twilio wasn't recognized, and it may just be a formatting/syntax thing as you mentioned.  I realize you aren't simply trying to send a text, but I set up a trial and tested out the Send a message action so that I could use Peek Code to see what the body of that request to Twilio looked like.  Here's the successful body:

 

15.png

 

Include your connection information in your headers in the HTTP action, and in the Body portion specify the "From" and "To," which is what appeared to be missing or invalid from your call.

 

Let us know how it goes!

Ashley

If you found this helpful, consider giving it a thumbs up!

Highlighted
Advocate I
Advocate I

Re: Using HTTP POST with Twilio

Hi Ashley,

Yes I did play around with this originally. It was not successful.

I have however dug to find more educational content to better understand the proper syntax that Twilio’s REST API is expecting.

This helped me a lot to understand what might be required from me in terms of a multipart form data POST. https://stackoverflow.com/questions/3508338/what-is-the-boundary-in-multipart-form-data

I’ll have some time tonight to play around with it and hopefully will have an update.

Thanks for your help!
Highlighted
Advocate I
Advocate I

Re: Using HTTP POST with Twilio

Good news, @AKRogers @edgonzales , I got it working!!!!

 

The key is to understand how the form data boundaries work, basically the form data needs to include a boundary that is declared by the user in the header. In your body , you use the boundary to delimit all the form data parts. In the body, you'll need to add two extra hyphens as a prefix of the declared boundary, when you are done adding the last type of form data you close the POST with the boundary plus two suffix hyphens. (code snippet below).

 

The header must be

Content-Type multipart/form-data; boundary=----YOURBOUNDARYHERE

 

Body 

------YOURBOUNDARYHERE
Content-Disposition: form-data; name="To"

+PHONE NUMBER HERE
------YOURBOUNDARYHERE
Content-Disposition: form-data; name="From"

+PHONE NUMBER HERE
------YOURBOUNDARYHERE--

 

 

 

Once I got the syntax, it was actually super easy. This exponentially expands the capabilities of using Twilio with flow. Thanks for all your advice!

 

 

View solution in original post

Highlighted
Helper V
Helper V

Re: Using HTTP POST with Twilio

My pleasure; great job!!

Ashley
Highlighted
Frequent Visitor

Re: Using HTTP POST with Twilio

I was also having a problem trying to POST to make a phone call, but I found a simpler method. If you use for Headers the key Content-Type and value application/x-www-form-urlencoded , you can the use the following as the Body:

To=%2B15555555555&From=%2B15555555555&Url=HTTPXMLURL

 

brave_rTBZeDjxsl.png

 

with %2B representing + and HTTPXMLURL in my case I used a link to a GitHub location that I put the TwiXL file:

 

<?xml version="1.0" encoding="UTF-8"?>
<Response>
<Say voice="alice">Assistance at the Employee Entrance. Repeat, assistance at the Employee Entrance.</Say>
</Response>

Highlighted
Advocate I
Advocate I

Re: Using HTTP POST with Twilio

Very cool, I will play around with this.

 

I ended up continuing to play with the Twilio API and began passing across optional parameters in JSON within the post to add context within my Twilio Flow. So I might just stick with how I currently have everything formatted to work.

 

It is good to know that there is a secondary way to achieving the same result though.

Highlighted
New Member

Re: Using HTTP POST with Twilio

Hi @edmm94

I am facing the same problem and I can't make it work.

Would it be possible to send a screen shot of the flow/HTTP step.

 

I would really appreciate this.

 

TIA 🙂

 

Highlighted
Advocate I
Advocate I

Re: Using HTTP POST with Twilio

@Maryam-8516 Sure thing, it might help if you send me a screenshot of your setup as well.  In my screenshot in authentication, I have it set to Basic with my Account SID and API password

 

 

 

 

Highlighted
Frequent Visitor

Re: Using HTTP POST with Twilio

How did you end up passing the optional parameters to Twilio through the REST API?

Highlighted
Advocate I
Advocate I

Re: Using HTTP POST with Twilio

@JNovosad  the optional parameters are sent as JSON. They would like something like this 

 

------WebKitFormBoundaryXXXXXXXXXXXX
Content-Disposition: form-data; name="Parameters"

{
"Department": "Value",
"OnsiteTech": "Value",
"UID": "Value",
"SiteName": "Value",
"ContactName": "Value"
}
------WebKitFormBoundaryXXXXXXXXXXXX
Content-Disposition: form-data; name="To"

+PHONENUMBER
------WebKitFormBoundaryXXXXXXXXXXXX
Content-Disposition: form-data; name="From"

+PHONENUMBER
------WebKitFormBoundaryXXXXXXXXXXXX--

Highlighted
Frequent Visitor

Re: Using HTTP POST with Twilio

Unfortunately, when I add in the Parameters bit, I'm back to getting the "Missing required parameter To in the post body" error message. Here is my HTTP POST request. I'm fairly certain I copied your solution correctly.

 

FlowIssue3.png

 

If I take out the Parameters part, and just have the "To" & "From", the call works perfectly.

Highlighted
Regular Visitor

Re: Using HTTP POST with Twilio

Simply brilliant! thanks a lot for sharing this - I applied the same logic in order to get a Salesforce token via Power automate, below the code in case that somebody might need it too:

 

 

------salesforceXX
Content-Disposition: form-data; name="username"

USERNAME
------salesforceXX
Content-Disposition: form-data; name="password"

PASSWORD+SECURITYTOKEN
------salesforceXX
Content-Disposition: form-data; name="grant_type"

password
------salesforceXX
Content-Disposition: form-data; name="client_id"

XXXXXXXXXXXXXXXXXXXXXXX
------salesforceXX
Content-Disposition: form-data; name="client_secret"

YYYYYYYYYYYYYYYYYYYYYYYY
------salesforceXX--

 

 

 

Helpful resources

Announcements
Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Upcoming Events

Experience what’s next for Power Automate

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Community Conference

Power Platform Community Conference

Find your favorite faces from the community presenting at the Power Platform Community Conference!

Top Solution Authors
Top Kudoed Authors
Users online (4,896)