cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Piotr_I
Level: Powered On

cannot create custom connector

Hi 

Trying to create custom connector with web app that provides some REST endpoints through which you can programmatically create, update, and submit requests. After providing info on General and Security tabs, the *URL on field the Definition tab is non editable grey without showing any value but showing a message "!Path not defined". Where is the trick or I make mistake?

 

Thanks for help

Piotr

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: cannot create custom connector

Hi Piotr_I,

 

I assume that you have seen this documentation on “Register and use custom connectors in Microsoft Flow”:
https://flow.microsoft.com/en-us/documentation/register-custom-api/

 

From this doc we know that in the Definitions tab, all the operations defined in your OpenAPI file or Postman Collection, along with request and response values, are auto-populated. While from the error message it seems that you have missed some parameters for the Path.

 

Please check your swagger file again. Hope this documentation could be your reference:
https://swagger.io/docs/specification/describing-parameters/

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

1 REPLY 1
Community Support Team
Community Support Team

Re: cannot create custom connector

Hi Piotr_I,

 

I assume that you have seen this documentation on “Register and use custom connectors in Microsoft Flow”:
https://flow.microsoft.com/en-us/documentation/register-custom-api/

 

From this doc we know that in the Definitions tab, all the operations defined in your OpenAPI file or Postman Collection, along with request and response values, are auto-populated. While from the error message it seems that you have missed some parameters for the Path.

 

Please check your swagger file again. Hope this documentation could be your reference:
https://swagger.io/docs/specification/describing-parameters/

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (6,823)